aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra')
-rw-r--r--meta-linaro/recipes-extra/odp/odp.bb12
-rw-r--r--meta-linaro/recipes-extra/odp/odp/0001-Replace-deprecated-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch41
2 files changed, 51 insertions, 2 deletions
diff --git a/meta-linaro/recipes-extra/odp/odp.bb b/meta-linaro/recipes-extra/odp/odp.bb
index c62f4dc3..4b5dd1ae 100644
--- a/meta-linaro/recipes-extra/odp/odp.bb
+++ b/meta-linaro/recipes-extra/odp/odp.bb
@@ -9,9 +9,11 @@ PV = "20140820+git${SRCPV}"
DEPENDS = "openssl"
-SRC_URI = "git://git.linaro.org/lng/odp.git;name=odp"
+SRC_URI = "git://git.linaro.org/lng/odp.git;name=odp \
+ file://0001-Replace-deprecated-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch \
+"
-SRCREV_odp = "26238333b5b0896366c844aeb7253e60abd99f5a"
+SRCREV_odp = "49bc9ee8fdd47c6193108a90c94ca3b3de66ba46"
SRCREV_FORMAT = "odp"
S = "${WORKDIR}/git"
@@ -20,5 +22,11 @@ inherit autotools
RDEPENDS_${PN} = "libcrypto"
+#PACKAGECONFIG ?= ""
+#PACKAGECONFIG[vald] = "--enable-test-vald,,,"
+#PACKAGECONFIG[perf] = "--enable-test-perf,,,"
+#PACKAGECONFIG[cunit] = "--enable-cunit,,cunit,cunit"
+#PACKAGECONFIG[cunit] = "--with-cunit-path=DIR,,cunit,"
+
# ODP primary shipped as static library plus some API test and samples/
FILES_${PN}-staticdev += "${datadir}/opendataplane/*.la"
diff --git a/meta-linaro/recipes-extra/odp/odp/0001-Replace-deprecated-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch b/meta-linaro/recipes-extra/odp/odp/0001-Replace-deprecated-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch
new file mode 100644
index 00000000..4173e081
--- /dev/null
+++ b/meta-linaro/recipes-extra/odp/odp/0001-Replace-deprecated-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch
@@ -0,0 +1,41 @@
+From fe143c348c887e2ffee61516aa631e41e4f752ba Mon Sep 17 00:00:00 2001
+From: "Gary S. Robertson" <gary.robertson@linaro.org>
+Date: Wed, 4 Mar 2015 17:16:16 -0600
+Subject: [PATCH] Replace deprecated _BSD_SOURCE with _DEFAULT_SOURCE
+
+Compilation of ODP v1.0 on OpenEmbedded failed due to
+the following warning being treated as an error:
+| In file included from /usr/include/stdlib.h:24:0,
+| from odp/example/ipsec/odp_ipsec.c:16:
+| /usr/include/features.h:148:3:
+| error: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated,
+| use _DEFAULT_SOURCE" [-Werror=cpp]
+| # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated,
+| use _DEFAULT_SOURCE"
+| ^
+
+Modified the source 'example/ipsec/odp_ipsec.c' as recommended.
+
+Upstream Status: Applied to lng/odp.git repository
+
+Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
+---
+ example/ipsec/odp_ipsec.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/example/ipsec/odp_ipsec.c b/example/ipsec/odp_ipsec.c
+index 70cd957..98160ba 100644
+--- a/example/ipsec/odp_ipsec.c
++++ b/example/ipsec/odp_ipsec.c
+@@ -10,7 +10,7 @@
+ * @example odp_example_ipsec.c ODP basic packet IO cross connect with IPsec test application
+ */
+
+-#define _BSD_SOURCE
++#define _DEFAULT_SOURCE
+ /* enable strtok */
+ #define _POSIX_C_SOURCE 200112L
+ #include <stdlib.h>
+--
+1.9.1
+