aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra/acpica/files/add-testing.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra/acpica/files/add-testing.patch')
-rw-r--r--meta-linaro/recipes-extra/acpica/files/add-testing.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/acpica/files/add-testing.patch b/meta-linaro/recipes-extra/acpica/files/add-testing.patch
new file mode 100644
index 00000000..30447c8f
--- /dev/null
+++ b/meta-linaro/recipes-extra/acpica/files/add-testing.patch
@@ -0,0 +1,32 @@
+Index: acpica-unix/Makefile
+===================================================================
+--- acpica-unix.orig/Makefile 2013-01-31 15:25:49.000000000 -0700
++++ acpica-unix/Makefile 2013-01-31 15:25:49.000000000 -0700
+@@ -14,3 +14,27 @@
+
+ include generate/unix/Makefile.config
+ include generate/unix/Makefile.common
++
++check:
++ cd tests
++
++ # ASL tests
++ $(CURDIR)/tests/aslts.sh $(CURDIR)/tests/aslts $(CURDIR)/generate/unix
++
++ # API Tests
++ $(CURDIR)/debian/run-aapits.sh $(CURDIR)/tests/aapits $(CURDIR)/generate/unix/bin
++
++ # misc tests
++ $(CURDIR)/debian/run-misc-tests.sh $(CURDIR) 20130626
++
++ # Template tests
++ cd $(CURDIR)/tests/templates
++ make
++ if [ -f diff.log ] ; \
++ then \
++ if [ -s diff.log ] ; \
++ then \
++ exit 1 # implies errors occurred ; \
++ fi ; \
++ fi
++