aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-devtools/gdb/gdb/gdbserver-cflags-last.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-devtools/gdb/gdb/gdbserver-cflags-last.diff')
-rw-r--r--meta-linaro/recipes-devtools/gdb/gdb/gdbserver-cflags-last.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-linaro/recipes-devtools/gdb/gdb/gdbserver-cflags-last.diff b/meta-linaro/recipes-devtools/gdb/gdb/gdbserver-cflags-last.diff
new file mode 100644
index 00000000..4dfc419c
--- /dev/null
+++ b/meta-linaro/recipes-devtools/gdb/gdb/gdbserver-cflags-last.diff
@@ -0,0 +1,25 @@
+Upstream-Status: Pending
+
+---
+ gdb/gdbserver/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- gdb/gdbserver/Makefile.in.orig
++++ gdb/gdbserver/Makefile.in
+@@ -118,14 +118,14 @@ WARN_CFLAGS_NO_FORMAT = `echo " $(WARN_C
+ # CFLAGS is specifically reserved for setting from the command line
+ # when running make. I.E. "make CFLAGS=-Wmissing-prototypes".
+ CFLAGS = @CFLAGS@
+
+ # INTERNAL_CFLAGS is the aggregate of all other *CFLAGS macros.
+-INTERNAL_CFLAGS_BASE = ${CFLAGS} ${GLOBAL_CFLAGS} \
++INTERNAL_CFLAGS_BASE = ${GLOBAL_CFLAGS} \
+ ${PROFILE_CFLAGS} ${INCLUDE_CFLAGS}
+ INTERNAL_WARN_CFLAGS = ${INTERNAL_CFLAGS_BASE} $(WARN_CFLAGS)
+-INTERNAL_CFLAGS = ${INTERNAL_WARN_CFLAGS} $(WERROR_CFLAGS) -DGDBSERVER
++INTERNAL_CFLAGS = ${INTERNAL_WARN_CFLAGS} $(WERROR_CFLAGS) ${CFLAGS} -DGDBSERVER
+
+ # LDFLAGS is specifically reserved for setting from the command line
+ # when running make.
+ LDFLAGS = @LDFLAGS@
+ INTERNAL_LDFLAGS = $(LDFLAGS) @RDYNAMIC@