aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64
diff options
context:
space:
mode:
Diffstat (limited to 'meta-aarch64')
-rw-r--r--meta-aarch64/recipes-core/coreutils/coreutils_8.21.bbappend3
-rw-r--r--meta-aarch64/recipes-core/coreutils/files/fix-longlong.patch45
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-aarch64/recipes-core/coreutils/coreutils_8.21.bbappend b/meta-aarch64/recipes-core/coreutils/coreutils_8.21.bbappend
new file mode 100644
index 00000000..4d43563f
--- /dev/null
+++ b/meta-aarch64/recipes-core/coreutils/coreutils_8.21.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append = " file://fix-longlong.patch"
diff --git a/meta-aarch64/recipes-core/coreutils/files/fix-longlong.patch b/meta-aarch64/recipes-core/coreutils/files/fix-longlong.patch
new file mode 100644
index 00000000..675a7efd
--- /dev/null
+++ b/meta-aarch64/recipes-core/coreutils/files/fix-longlong.patch
@@ -0,0 +1,45 @@
+From 9fe7c5b6eb373d859390dd5a7844a666d8b7818b Mon Sep 17 00:00:00 2001
+From: Torbjörn Granlund <tg@gmplib.org>
+Date: Mon, 04 Mar 2013 17:57:33 +0000
+Subject: build: fix factor build failure on aarch64
+
+* src/longlong.h (__aarch64__): Make add_ssaaaa and sub_ddmmss work.
+* NEWS: Mention the build fix.
+Reported at https://bugzilla.redhat.com/917735
+---
+(limited to 'src/longlong.h')
+
+--- a/src/longlong.h
++++ b/src/longlong.h
+@@ -529,23 +529,16 @@
+ #endif /* __arm__ */
+
+ #if defined (__aarch64__) && W_TYPE_SIZE == 64
++/* FIXME: Extend the immediate range for the low word by using both
++ ADDS and SUBS, since they set carry in the same way. */
+ #define add_ssaaaa(sh, sl, ah, al, bh, bl) \
+- __asm__ ("adds\t%1, %4, %5\n\tadc\t%0, %2, %3" \
+- : "=r" (sh), "=&r" (sl) \
+- : "r" (ah), "rZ" (bh), "%r" (al), "rI" (bl) __CLOBBER_CC)
++ __asm__ ("adds\t%1, %x4, %5\n\tadc\t%0, %x2, %x3" \
++ : "=r" (sh), "=&r" (sl) \
++ : "rZ" (ah), "rZ" (bh), "%r" (al), "rI" (bl) __CLOBBER_CC)
+ #define sub_ddmmss(sh, sl, ah, al, bh, bl) \
+- do { \
+- if (__builtin_constant_p (bl)) \
+- { \
+- __asm__ ("subs\t%1, %4, %5\n\tsbc\t%0, %2, %3" \
+- : "=r" (sh), "=&r" (sl) \
+- : "r" (ah), "r" (bh), "r" (al), "rI" (bl) __CLOBBER_CC); \
+- } \
+- else /* only bh might be a constant */ \
+- __asm__ ("subs\t%1, %4, %5\n\tsbc\t%0, %2, %3" \
+- : "=r" (sh), "=&r" (sl) \
+- : "r" (ah), "rZ" (bh), "r" (al), "rI" (bl) __CLOBBER_CC);\
+- } while (0)
++ __asm__ ("subs\t%1, %x4, %5\n\tsbc\t%0, %x2, %x3" \
++ : "=r,r" (sh), "=&r,&r" (sl) \
++ : "rZ,rZ" (ah), "rZ,rZ" (bh), "r,Z" (al), "rI,r" (bl) __CLOBBER_CC)
+ #define umul_ppmm(ph, pl, m0, m1) \
+ do { \
+ UDItype __m0 = (m0), __m1 = (m1); \