aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64/recipes-devtools/gcc/gcc-4.7/disable_relax_pic_calls_flag.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-aarch64/recipes-devtools/gcc/gcc-4.7/disable_relax_pic_calls_flag.patch')
-rw-r--r--meta-aarch64/recipes-devtools/gcc/gcc-4.7/disable_relax_pic_calls_flag.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta-aarch64/recipes-devtools/gcc/gcc-4.7/disable_relax_pic_calls_flag.patch b/meta-aarch64/recipes-devtools/gcc/gcc-4.7/disable_relax_pic_calls_flag.patch
deleted file mode 100644
index bc01cd91..00000000
--- a/meta-aarch64/recipes-devtools/gcc/gcc-4.7/disable_relax_pic_calls_flag.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-GCC: disable MASK_RELAX_PIC_CALLS bit
-
-The new feature added after 4.3.3
-"http://www.pubbs.net/200909/gcc/94048-patch-add-support-for-rmipsjalr.html"
-will cause cc1plus eat up all the system memory when build webkit-gtk.
-The function mips_get_pic_call_symbol keeps on recursively calling itself.
-Disable this feature to walk aside the bug.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-Index: gcc-4_7-branch/gcc/configure
-===================================================================
---- gcc-4_7-branch.orig/gcc/configure 2012-04-10 10:37:09.351387437 -0700
-+++ gcc-4_7-branch/gcc/configure 2012-04-10 10:37:57.211389779 -0700
-@@ -25837,13 +25837,6 @@
- rm -f conftest.*
- fi
- fi
-- if test $gcc_cv_as_ld_jalr_reloc = yes; then
-- if test x$target_cpu_default = x; then
-- target_cpu_default=MASK_RELAX_PIC_CALLS
-- else
-- target_cpu_default="($target_cpu_default)|MASK_RELAX_PIC_CALLS"
-- fi
-- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_as_ld_jalr_reloc" >&5
- $as_echo "$gcc_cv_as_ld_jalr_reloc" >&6; }
-
-Index: gcc-4_7-branch/gcc/configure.ac
-===================================================================
---- gcc-4_7-branch.orig/gcc/configure.ac 2012-04-10 10:37:09.339387366 -0700
-+++ gcc-4_7-branch/gcc/configure.ac 2012-04-10 10:37:57.215389769 -0700
-@@ -4027,13 +4027,6 @@
- rm -f conftest.*
- fi
- fi
-- if test $gcc_cv_as_ld_jalr_reloc = yes; then
-- if test x$target_cpu_default = x; then
-- target_cpu_default=MASK_RELAX_PIC_CALLS
-- else
-- target_cpu_default="($target_cpu_default)|MASK_RELAX_PIC_CALLS"
-- fi
-- fi
- AC_MSG_RESULT($gcc_cv_as_ld_jalr_reloc)
-
- AC_CACHE_CHECK([linker for .eh_frame personality relaxation],