aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta-bigendian/recipes-devtools/python/python-numpy/armeb/config.h21
-rw-r--r--meta-bigendian/recipes-devtools/python/python-numpy/armeb/numpyconfig.h17
-rw-r--r--meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend8
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-lng.bb3
4 files changed, 48 insertions, 1 deletions
diff --git a/meta-bigendian/recipes-devtools/python/python-numpy/armeb/config.h b/meta-bigendian/recipes-devtools/python/python-numpy/armeb/config.h
new file mode 100644
index 00000000..17ef186d
--- /dev/null
+++ b/meta-bigendian/recipes-devtools/python/python-numpy/armeb/config.h
@@ -0,0 +1,21 @@
+/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
+/* #define SIZEOF_SHORT 2 */
+/* #define SIZEOF_INT 4 */
+/* #define SIZEOF_LONG 4 */
+/* #define SIZEOF_FLOAT 4 */
+/* #define SIZEOF_DOUBLE 8 */
+#define SIZEOF_LONG_DOUBLE 12
+#define SIZEOF_PY_INTPTR_T 4
+/* #define SIZEOF_LONG_LONG 8 */
+#define SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+#define MATHLIB m
+#define HAVE_FLOAT_FUNCS
+#define HAVE_LOG1P
+#define HAVE_EXPM1
+#define HAVE_INVERSE_HYPERBOLIC
+#define HAVE_INVERSE_HYPERBOLIC_FLOAT
+#define HAVE_ISNAN
+#define HAVE_ISINF
+#define HAVE_RINT
+
diff --git a/meta-bigendian/recipes-devtools/python/python-numpy/armeb/numpyconfig.h b/meta-bigendian/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
new file mode 100644
index 00000000..c4bf6547
--- /dev/null
+++ b/meta-bigendian/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+
diff --git a/meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend b/meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend
new file mode 100644
index 00000000..aa9df9ad
--- /dev/null
+++ b/meta-bigendian/recipes-devtools/python/python-numpy_1.7.0.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " ${CONFIGFILESURI} "
+
+CONFIGFILESURI_armeb = " \
+ file://config.h \
+ file://numpyconfig.h \
+"
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-lng.bb b/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
index 72366380..6bc8c4b9 100644
--- a/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
+++ b/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
@@ -11,6 +11,7 @@ IMAGE_INSTALL += " \
netperf \
openvswitch \
procps \
+ python-numpy \
qemu \
rt-tests \
trinity-example \
@@ -22,7 +23,7 @@ IMAGE_INSTALL_append_armv7a = " \
valgrind \
"
-IMAGE_INSTALL_append_genericarmv7a = "python-numpy"
+#IMAGE_INSTALL_append_genericarmv7a = "python-numpy"
IMAGE_FEATURES += "\
dev-pkgs \