aboutsummaryrefslogtreecommitdiff
path: root/meta-optee
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-02-17 11:00:13 +0200
committerKoen Kooi <koen.kooi@linaro.org>2017-02-17 09:34:13 +0000
commit27ccce6ad2dc117176d35910cf9ad3cfd3574c32 (patch)
tree18e99f8ca79cc48887d46ca2c8474bb52ebe95d4 /meta-optee
parentc8328b07618ae60f43465eb8c9eec77572d31032 (diff)
optee: uprev client/os/test to 2.3.0
* optee-client: avoid to fix up the hardcoded paths. Run oe-runmake install, and then install the files in the location we expect them. * optee-test: *.ta install path should match the value set in optee-client. Default TEEC_LOAD_PATH is /lib. Adjust the install path to match the default. Change-Id: Iecd10bac760c5b68e0796ba595f8fa55f4785fda Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-optee')
-rw-r--r--meta-optee/recipes-security/optee/optee-client.bb26
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb4
-rw-r--r--meta-optee/recipes-security/optee/optee-test_git.bb18
3 files changed, 18 insertions, 30 deletions
diff --git a/meta-optee/recipes-security/optee/optee-client.bb b/meta-optee/recipes-security/optee/optee-client.bb
index 411635e9..c31fb307 100644
--- a/meta-optee/recipes-security/optee/optee-client.bb
+++ b/meta-optee/recipes-security/optee/optee-client.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/OP-TEE/optee_client"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=a6d62e1b5fef18a1854bd538e3160d7c"
-PV = "2.2.0+git${SRCPV}"
+PV = "2.3.0+git${SRCPV}"
inherit pythonnative systemd
@@ -12,29 +12,20 @@ SRC_URI = "git://github.com/OP-TEE/optee_client.git \
file://tee-supplicant.service"
S = "${WORKDIR}/git"
-SRCREV = "658ae538f76a2624b7f9c40539a600d281d872b4"
+SRCREV = "365657667f8968f40237480169fea44fa3fb9949"
SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
-do_compile() {
- install -d ${D}${prefix}
- oe_runmake EXPORT_DIR=${D}${prefix}
-}
-
do_install() {
- install -d ${D}${libdir}
- install -d ${D}${bindir}
+ oe_runmake install
- # fix up hardcoded /lib paths
- sed -i -e 's:EXPORT_DIR}/lib:EXPORT_DIR}${base_libdir}:g' ${S}/Makefile
+ install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant
- oe_runmake install EXPORT_DIR=${D}${prefix}
+ install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
+ ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
+ ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
- ( cd ${D}${libdir}
- rm libteec.so libteec.so.1
- ln -s libteec.so.1.0 libteec.so.1
- ln -s libteec.so.1.0 libteec.so
- )
+ cp -a ${S}/out/export/include ${D}/usr/
sed -i -e s:/etc:${sysconfdir}:g \
-e s:/usr/bin:${bindir}:g \
@@ -42,4 +33,3 @@ do_install() {
install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service
}
-
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index 009f8826..a194c8c0 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -4,13 +4,13 @@ DESCRIPTION = "OPTEE OS"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
-PV="2.2.0+git${SRCPV}"
+PV="2.3.0+git${SRCPV}"
DEPENDS = "python-wand-native python-pycrypto-native"
inherit deploy pythonnative
-SRCREV = "c0c5d399d81a0669f5c8e3bcb20039d65649a78d"
+SRCREV = "28fcee179fc908ee2001a135179366d794af7878"
SRC_URI = "git://github.com/OP-TEE/optee_os.git \
file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
"
diff --git a/meta-optee/recipes-security/optee/optee-test_git.bb b/meta-optee/recipes-security/optee/optee-test_git.bb
index 2b2b48c9..3fd267c4 100644
--- a/meta-optee/recipes-security/optee/optee-test_git.bb
+++ b/meta-optee/recipes-security/optee/optee-test_git.bb
@@ -8,14 +8,14 @@ DEPENDS = "optee-client optee-os python-pycrypto-native"
inherit pythonnative
-PV = "2.2.0+git${SRCPV}"
+PV = "2.3.0+git${SRCPV}"
SRC_URI = "git://github.com/OP-TEE/optee_test.git \
file://fix-build-failure-with-GCC6.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "a00eeb15ddfaa5b7d2cb340faeb36748d5aabffb"
+SRCREV = "a4653559d989d5006f67f4498be4cb090be12f79"
OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"
@@ -36,17 +36,15 @@ do_compile() {
}
do_install () {
- install -d ${D}${bindir}
- install -d ${D}${base_libdir}/optee_armtz
+ install -D -p -m0755 ${S}/out/xtest/xtest ${D}${bindir}/xtest
- install ${S}/out/xtest/xtest ${D}${bindir}
-
- find ${S}/out/ta -name '*.ta' | while read name; do
- install -m 444 $name ${D}${base_libdir}/optee_armtz/
- done
+ # install path should match the value set in optee-client/tee-supplicant
+ # default TEEC_LOAD_PATH is /lib
+ mkdir -p ${D}/lib/optee_armtz/
+ install -D -p -m0444 ${S}/out/ta/*/*.ta ${D}/lib/optee_armtz/
}
-FILES_${PN} += "${base_libdir}/optee_armtz/"
+FILES_${PN} += "/lib/optee_armtz/"
# Imports machine specific configs from staging to build
PACKAGE_ARCH = "${MACHINE_ARCH}"