aboutsummaryrefslogtreecommitdiff
path: root/meta-optee
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2018-02-27 17:30:30 +0000
committerPeter Griffin <peter.griffin@linaro.org>2018-02-27 17:30:30 +0000
commit440907a7dfd5142ed5a3b5957dc06881fab7ce89 (patch)
tree929b2c823a94ebba6fb093d70460a13d8a658c2e /meta-optee
parent5d2cb685217794293ea2bab18d7e62019c329d06 (diff)
optee: Add enable cache API patch for HiKey.
ClearKey, Widevine & Playready TA's when decrypting into secure buffers, need to manage the cache. This patch has already been upstreamed, but is required in optee-2.4.0 for morty based builds. Change-Id: I6a115d1aa3ea890c771c3c0874ea3787f3401e33 Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
Diffstat (limited to 'meta-optee')
-rw-r--r--meta-optee/recipes-security/optee/optee-os/0001-hikey-Enable-cache-APIs-for-hikey-platform.patch29
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-optee/recipes-security/optee/optee-os/0001-hikey-Enable-cache-APIs-for-hikey-platform.patch b/meta-optee/recipes-security/optee/optee-os/0001-hikey-Enable-cache-APIs-for-hikey-platform.patch
new file mode 100644
index 00000000..bf0b3750
--- /dev/null
+++ b/meta-optee/recipes-security/optee/optee-os/0001-hikey-Enable-cache-APIs-for-hikey-platform.patch
@@ -0,0 +1,29 @@
+From 6571543970b88c13a4452e6b8b3db1ae41823efc Mon Sep 17 00:00:00 2001
+From: Peter Griffin <peter.griffin@linaro.org>
+Date: Tue, 27 Feb 2018 16:26:34 +0000
+Subject: [PATCH] hikey: Enable cache APIs for hikey platform.
+
+When decrypting into SDP buffers TA's like Playready
+and Widevine need to be able to flush the cache.
+
+Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
+---
+ core/arch/arm/plat-hikey/conf.mk | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/core/arch/arm/plat-hikey/conf.mk b/core/arch/arm/plat-hikey/conf.mk
+index 8a8ef2f..ebac1c7 100644
+--- a/core/arch/arm/plat-hikey/conf.mk
++++ b/core/arch/arm/plat-hikey/conf.mk
+@@ -11,6 +11,8 @@ $(call force,CFG_PM_STUBS,y)
+ $(call force,CFG_SECURE_TIME_SOURCE_CNTPCT,y)
+ $(call force,CFG_WITH_ARM_TRUSTED_FW,y)
+
++CFG_CACHE_API ?= y
++
+ ta-targets = ta_arm32
+
+ ifeq ($(CFG_ARM64_core),y)
+--
+2.7.4
+
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index 7c44cc20..44ce69e5 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -13,7 +13,8 @@ inherit deploy pythonnative
SRCREV = "702609a7a5ff8c05ab54bc967d762f1acf18fd9d"
SRC_URI = "git://github.com/OP-TEE/optee_os.git \
file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
- "
+ file://0001-hikey-Enable-cache-APIs-for-hikey-platform.patch \
+ "
S = "${WORKDIR}/git"