aboutsummaryrefslogtreecommitdiff
path: root/meta-optee/recipes-security
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2016-05-20 09:46:31 +0200
committerKoen Kooi <koen.kooi@linaro.org>2016-05-20 09:53:45 +0200
commit870bb6c47f05bacf28dd4d894cea5dbee7ea75df (patch)
tree27bffb29dbf4a5d8759fb443a459e1700df91ca1 /meta-optee/recipes-security
parenta5d6db26e1bf6a398fcaf87d5a8f2365cbc54090 (diff)
optee-client: add recipe for 2.0 release
Change-Id: Ib3ff22628c63eaf6f0be9b9a698b70f667b72535 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-optee/recipes-security')
-rw-r--r--meta-optee/recipes-security/optee/optee-client.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-optee/recipes-security/optee/optee-client.bb b/meta-optee/recipes-security/optee/optee-client.bb
new file mode 100644
index 00000000..c49613d7
--- /dev/null
+++ b/meta-optee/recipes-security/optee/optee-client.bb
@@ -0,0 +1,29 @@
+SUMMARY = "OPTEE Client"
+HOMEPAGE = "https://github.com/OP-TEE/optee_client"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
+
+PV = "2.0.0+git${SRCPV}"
+
+SRC_URI = "git://github.com/OP-TEE/optee_client.git"
+S = "${WORKDIR}/git"
+
+SRCREV = "88acd6bda5f9e19124fce0015fe64a6644eff036"
+
+do_compile() {
+ install -d ${D}${prefix}
+ oe_runmake EXPORT_DIR=${D}${prefix}/
+}
+
+do_install() {
+ install -d ${D}${prefix}
+ oe_runmake install EXPORT_DIR=${D}${prefix}
+
+ ( cd ${D}${prefix}/lib
+ rm libteec.so libteec.so.1
+ ln -s libteec.so.1.0 libteec.so.1
+ ln -s libteec.so.1.0 libteec.so
+ )
+}
+