aboutsummaryrefslogtreecommitdiff
path: root/meta-optee/recipes-security
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-10-26 21:22:55 +0300
committerFathi Boudra <fathi.boudra@linaro.org>2017-10-26 21:22:55 +0300
commit837fb7d048a30baa6356d3ceb493ec20074b8785 (patch)
tree1e43ee1f7964ddbbbba843d2203cf03eb73adfb0 /meta-optee/recipes-security
parentb3b7dea07cd3b04315bc2745afaf8dd377c7f6c0 (diff)
optee: update to 2.6.0 release
* Drop python-wand and imagemagick, they aren't used anymore. * Update PV/SRCREV for optee-client, optee-os and optee-test to 2.6.0 release. * Refresh optee-client patch to apply on the new release. Change-Id: Ie61850457af76d1affb14b39d9702f48c8ac4399 Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-optee/recipes-security')
-rw-r--r--meta-optee/recipes-security/optee/optee-client.bb6
-rw-r--r--meta-optee/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch58
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb11
-rw-r--r--meta-optee/recipes-security/optee/optee-test_git.bb4
4 files changed, 19 insertions, 60 deletions
diff --git a/meta-optee/recipes-security/optee/optee-client.bb b/meta-optee/recipes-security/optee/optee-client.bb
index 4c5ac1a9..d0773c93 100644
--- a/meta-optee/recipes-security/optee/optee-client.bb
+++ b/meta-optee/recipes-security/optee/optee-client.bb
@@ -2,9 +2,9 @@ SUMMARY = "OPTEE Client"
HOMEPAGE = "https://github.com/OP-TEE/optee_client"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=a6d62e1b5fef18a1854bd538e3160d7c"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
-PV = "2.4.0+git${SRCPV}"
+PV = "2.6.0+git${SRCPV}"
inherit pythonnative systemd
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/OP-TEE/optee_client.git \
file://tee-supplicant.service"
S = "${WORKDIR}/git"
-SRCREV = "1df4046bd729e866743454a18a71e72228e585fd"
+SRCREV = "73b4e490a8ed0b4a7714818e80998b9d8a7da958"
SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
diff --git a/meta-optee/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch b/meta-optee/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch
index 4d25b765..8dd6c7a9 100644
--- a/meta-optee/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch
+++ b/meta-optee/recipes-security/optee/optee-client/0001-Respect-LDFLAGS-set-from-OE-build.patch
@@ -15,45 +15,17 @@ Upstream-Status: Pending
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
- libsqlfs/Makefile | 2 +-
- libsqlite3/Makefile | 2 +-
- libteec/Makefile | 2 +-
- tee-supplicant/Makefile | 10 +++++-----
- 4 files changed, 8 insertions(+), 8 deletions(-)
+ libteec/Makefile | 2 +-
+ tee-supplicant/Makefile | 8 ++++----
+ 2 files changed, 5 insertions(+), 5 deletions(-)
-diff --git a/libsqlfs/Makefile b/libsqlfs/Makefile
-index b53ccde..7a3bde6 100644
---- a/libsqlfs/Makefile
-+++ b/libsqlfs/Makefile
-@@ -38,7 +38,7 @@ SQLFS_CFLAGS := $(addprefix -I, $(SQLFS_INCLUDES)) \
- $(filter-out $(SQLFS_CFLAGS_REMOVE),$(CFLAGS)) \
- -Wno-missing-format-attribute
-
--SQLFS_LFLAGS := -lpthread
-+SQLFS_LFLAGS := $(LDFLAGS) -lpthread
- SQLFS_LIBS := $(OUT_DIR)/../libsqlite3/libsqlite3.a
- SQLFS_LIBRARY := $(OUT_DIR)/$(LIB_MAJ_MIN)
-
-diff --git a/libsqlite3/Makefile b/libsqlite3/Makefile
-index a69aabd..6a6d833 100644
---- a/libsqlite3/Makefile
-+++ b/libsqlite3/Makefile
-@@ -19,7 +19,7 @@ SQLITE3_CFLAGS_REMOVE := -Wall -Wbad-function-cast -Wswitch-default \
- -Wfloat-equal -Werror -Wwrite-strings -Wcast-align
- SQLITE3_CFLAGS := $(addprefix -I, $(SQLITE3_INCLUDES)) \
- $(filter-out $(SQLITE3_CFLAGS_REMOVE),$(CFLAGS))
--SQLITE3_LFLAGS :=
-+SQLITE3_LFLAGS := $(LDFLAGS)
- SQLITE3_LIBRARY := $(OUT_DIR)/$(LIB_NAME)
-
- libsqlite3: $(SQLITE3_LIBRARY)
diff --git a/libteec/Makefile b/libteec/Makefile
-index 66055a7..d3eb2a1 100644
+index 568a2cd..a406237 100644
--- a/libteec/Makefile
+++ b/libteec/Makefile
-@@ -29,7 +29,7 @@ TEEC_CFLAGS := $(addprefix -I, $(TEEC_INCLUDES)) $(CFLAGS) -D_GNU_SOURCE \
- -DDEBUGLEVEL_$(CFG_TEE_CLIENT_LOG_LEVEL) \
- -DBINARY_PREFIX=\"TEEC\"
+@@ -36,7 +36,7 @@ ifeq ($(CFG_TEE_BENCHMARK),y)
+ TEEC_CFLAGS += -DCFG_TEE_BENCHMARK
+ endif
-TEEC_LFLAGS := -lpthread
+TEEC_LFLAGS := $(LDFLAGS) -lpthread
@@ -61,26 +33,16 @@ index 66055a7..d3eb2a1 100644
libteec: $(TEEC_LIBRARY)
diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
-index 204273f..40df763 100644
+index 737d39a..4b423fb 100644
--- a/tee-supplicant/Makefile
+++ b/tee-supplicant/Makefile
-@@ -57,7 +57,7 @@ ifeq ($(CFG_TA_TEST_PATH),y)
+@@ -55,21 +55,21 @@ ifeq ($(CFG_TA_TEST_PATH),y)
TEES_CFLAGS += -DCFG_TA_TEST_PATH=1
endif
TEES_FILE := $(OUT_DIR)/$(PACKAGE_NAME)
-TEES_LDFLAGS := -L$(OUT_DIR)/../libteec -lteec
+TEES_LFLAGS := $(LDFLAGS) -L$(OUT_DIR)/../libteec -lteec
- ifeq ($(CFG_SQL_FS),y)
- TEES_CFLAGS += -DCFG_SQL_FS
-@@ -67,22 +67,22 @@ TEES_CFLAGS_sql_fs.c := -Wno-strict-prototypes \
- # Note: explicitly requesting a shared library (.so) here, because statically
- # linking a LGPL library has licensing implications. Make sure you review
- # and comply with libsqlfs/COPYING section 6 before doing so.
--TEES_LDFLAGS += -L$(OUT_DIR)/../libsqlfs -l:libsqlfs.so -ldl
-+TEES_LFLAGS += -L$(OUT_DIR)/../libsqlfs -l:libsqlfs.so -ldl
- endif
-
ifeq ($(CFG_TA_GPROF_SUPPORT),y)
TEES_CFLAGS += -DCFG_TA_GPROF_SUPPORT
endif
@@ -101,5 +63,5 @@ index 204273f..40df763 100644
$(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c
--
-1.9.1
+2.15.0.rc2
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index da1a1d67..81f60c9c 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -4,14 +4,14 @@ DESCRIPTION = "OPTEE OS"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
-PV="2.5.0+git${SRCPV}"
+PV="2.6.0+git${SRCPV}"
-DEPENDS = "python-wand-native python-pycrypto-native"
+DEPENDS = "python-pycrypto-native"
inherit deploy pythonnative
-SRCREV = "3ff350a12d634bd7c4375ff347254977e9fb5a52"
-SRC_URI = "git://github.com/OP-TEE/optee_os.git \
+SRCREV = "a5edec8d0baa967a389b6f54be3b9bbce32c330c"
+SRC_URI = "git://github.com/OP-TEE/optee_os.git;nobranch=1 \
file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
"
@@ -29,9 +29,6 @@ EXTRA_OEMAKE = "PLATFORM=${OPTEEMACHINE} CFG_ARM64_core=y \
LIBGCC_LOCATE_CFLAGS=--sysroot=${STAGING_DIR_HOST} \
"
-# Needed so that python-wand can find the installed imagemagick install.
-export MAGICK_HOME="${STAGING_DIR_NATIVE}${prefix}"
-
OPTEE_ARCH_armv7a = "arm32"
OPTEE_ARCH_aarch64 = "arm64"
diff --git a/meta-optee/recipes-security/optee/optee-test_git.bb b/meta-optee/recipes-security/optee/optee-test_git.bb
index 03147b09..2d85d89e 100644
--- a/meta-optee/recipes-security/optee/optee-test_git.bb
+++ b/meta-optee/recipes-security/optee/optee-test_git.bb
@@ -8,14 +8,14 @@ DEPENDS = "optee-client optee-os python-pycrypto-native"
inherit pythonnative
-PV = "2.4.0+git${SRCPV}"
+PV = "2.6.0+git${SRCPV}"
SRC_URI = "git://github.com/OP-TEE/optee_test.git \
file://fix-build-failure-with-GCC6.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "213ca8aaf4eafe9d26af76db7b31d9595ce57e6f"
+SRCREV = "cc72dd2ce5c45318ad1618633bf0c859ad56cd8a"
OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
TEEC_EXPORT = "${STAGING_DIR_HOST}${prefix}"