aboutsummaryrefslogtreecommitdiff
path: root/meta-optee/recipes-security
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-01-18 13:22:48 +0200
committerFathi Boudra <fathi.boudra@linaro.org>2017-01-18 13:29:14 +0200
commit05eae57fa1f6660d18828f500fcad37091485745 (patch)
treedc593cfb11d6339626bc5bbb88580f20607e3fc8 /meta-optee/recipes-security
parentd13fbecbe56cb69f34d920baa08b95f4422f594b (diff)
optee-os: fix build failure with GCC 6
Add NOWERROR=1 to disable errors introduced with the upgrade to GCC 6: error: dereferencing type-punned pointer might break strict-aliasing rules [-Werror=strict-aliasing] Change-Id: Ibf95883c1fb105dc661cede5311beddd02ddd4c1 Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-optee/recipes-security')
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index 77d93b67..009f8826 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -21,9 +21,11 @@ OPTEEMACHINE ?= "${MACHINE}"
OPTEEOUTPUTMACHINE ?= "${MACHINE}"
EXTRA_OEMAKE = "PLATFORM=${OPTEEMACHINE} CFG_ARM64_core=y \
- CROSS_COMPILE_core=${HOST_PREFIX} \
- CROSS_COMPILE_ta_arm64=${HOST_PREFIX} \
+ CROSS_COMPILE_core=${HOST_PREFIX} \
+ CROSS_COMPILE_ta_arm64=${HOST_PREFIX} \
+ NOWERROR=1 \
ta-targets=ta_arm64 \
+ LDFLAGS= \
LIBGCC_LOCATE_CFLAGS=--sysroot=${STAGING_DIR_HOST} \
"