aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2013-12-03 14:20:27 +0200
committerFathi Boudra <fathi.boudra@linaro.org>2013-12-04 09:39:44 +0200
commitd12bf93418594f80d46ec70929be827081887f1f (patch)
tree47534a34f35c2a0a0ee4769b3ee1c640be258d4c /meta-linaro
parent9d71745792bfe40e01221f75d74bfff9bf37571d (diff)
Add Linaro Powerdebug recipe
Change-Id: I359f0ff083f973a3441ab3d40c7333ab33113b4c Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-extra/powerdebug/powerdebug_0.7.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/powerdebug/powerdebug_0.7.1.bb b/meta-linaro/recipes-extra/powerdebug/powerdebug_0.7.1.bb
new file mode 100644
index 00000000..7cc3a5db
--- /dev/null
+++ b/meta-linaro/recipes-extra/powerdebug/powerdebug_0.7.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "tool to display regulator, sensor and clock information"
+SUMMARY = "PowerDebug is a tool to display regulator, sensor and clock \
+information. Data is refreshed every few seconds. There is also dump option \
+to display the information just once."
+LICENSE = "EPL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cdd7b8fa70e88be67e325baae3b8ee95"
+DEPENDS = "ncurses"
+
+MMYY = "13.09"
+RELEASE = "20${MMYY}"
+
+SRC_URI = "http://releases.linaro.org/${MMYY}/components/power-management/powerdebug/linaro-powerdebug-${PV}-${RELEASE}.tar.bz2"
+
+SRC_URI[md5sum] = "39ca9b9d28b12672b2b98940aea80267"
+SRC_URI[sha256sum] = "541eb0507c4868a10ed86bde334bc94f37f891cd2bab97326633c7ddb301407d"
+
+S = "${WORKDIR}/powerdebug-${PV}-${RELEASE}"
+
+do_install () {
+ install -D -p -m0755 powerdebug ${D}/${sbindir}/powerdebug
+ install -D -p -m0644 powerdebug.8 ${D}${mandir}/man8/powerdebug.8
+}