aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2013-09-16 14:57:02 +0300
committerRiku Voipio <riku.voipio@linaro.org>2013-09-16 14:57:02 +0300
commitff4768bbc6d155f4b310b67b471b079bbcbd4f49 (patch)
tree99e7338699e3ca2839ab6ac4d81de7ee17ce7a07 /meta-linaro
parentb7312984944035b8e0f80412b13012536ffed952 (diff)
add gator recipe
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
new file mode 100644
index 00000000..113f1334
--- /dev/null
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Target-side daemon gathering data for ARM Streamline Performance Analyzer."
+SUMMARY = "DS-5 Gator daemon"
+
+LICENSE = "GPL-2"
+LIC_FILES_CHKSUM = "file://driver/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://git.linaro.org/arm/ds5/gator.git"
+
+SRCREV = "${AUTOREV}"
+
+S = "${WORKDIR}/git"
+
+PV = "5.15+git${SRCPV}"
+PR = "r1"
+
+do_compile() {
+ cd daemon
+ make CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}
+}
+
+do_install() {
+ install -D -p -m0755 daemon/gatord ${D}/${sbindir}/gatord
+}