aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2015-01-15 18:36:50 +0800
committerFathi Boudra <fathi.boudra@linaro.org>2015-01-15 10:49:41 +0000
commitb274662e96eb32824ba8f8cb3843f70372cdf027 (patch)
tree516bc253cde2099b4590b40b85c913b90c222b56 /meta-linaro
parent602ce008e2747c07e4d286299750e1161fc2ddc4 (diff)
bootwrapper: fix the configure error
Since kernel commit ca5b34100c57 ("dts, arm64: Move dts files to vendor subdirs"), the default dtb directory in bootwrapper is not matched with the kernel and it would provoke the following error when checking the dtb in configure: checking for build/arch/arm64/boot/dts/rtsm_ve-aemv8a.dtb... no configure: error: No such file or directory: build/arch/arm64/boot/dts/rtsm_ve-aemv8a.dtb WARNING: temp/run.do_compile.5170:1 exit 1 from The latest bootwrapper adds a "--with-dtb" to override the default dtb in configure.ac. So update the bootwrapper to the latest version and use the "--with-dtb" option to workaround this build issue. Change-Id: Ic664e959ce8adb742dfce5b12b1981fbb3995e56 Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-kernel/linux/bootwrapper.inc19
1 files changed, 12 insertions, 7 deletions
diff --git a/meta-linaro/recipes-kernel/linux/bootwrapper.inc b/meta-linaro/recipes-kernel/linux/bootwrapper.inc
index cbe5a068..627c320b 100644
--- a/meta-linaro/recipes-kernel/linux/bootwrapper.inc
+++ b/meta-linaro/recipes-kernel/linux/bootwrapper.inc
@@ -1,7 +1,7 @@
SRC_URI_append= " git://git.kernel.org/pub/scm/linux/kernel/git/cmarinas/boot-wrapper-aarch64.git;protocol=http;branch=master;name=bootwrapper;destsuffix=bootwrapper \
"
-SRCREV_bootwrapper = "2ff0b45423226d3de898a52a81b8e90b20fecd60"
+SRCREV_bootwrapper = "26a17ad59544f026878efdb0524ce66b7a314784"
BW = "${WORKDIR}/bootwrapper"
DTBDIR="${B}/arch/arm64/boot/dts/"
@@ -24,26 +24,31 @@ do_compile_append() {
export LDFLAGS="${WRAPLDFLAGS}"
autoreconf -vfi
+ dtb=`find ${DTBDIR} -type f -name "foundation-v8.dtb"`
./configure --host=aarch64-linux-gnu \
--with-kernel-dir="${B}" \
- --with-cmdline="${BOOTARGS_COMMON} root=/dev/vda"
+ --with-cmdline="${BOOTARGS_COMMON} root=/dev/vda" \
+ --with-dtb="${dtb}"
make IMAGE=linux-system-foundation.axf clean
make DTC=${B}/scripts/dtc/dtc \
- KERNEL_DTB=`find ${DTBDIR} -type f -name "foundation-v8.dtb"` \
+ KERNEL_DTB="${dtb}" \
IMAGE=linux-system-foundation.axf
make IMAGE=img-foundation.axf clean
./configure --host=aarch64-linux-gnu \
--with-kernel-dir="${B}" \
- --with-cmdline="${BOOTARGS_COMMON} root=/dev/vda2"
+ --with-cmdline="${BOOTARGS_COMMON} root=/dev/vda2" \
+ --with-dtb="${dtb}"
make DTC=${B}/scripts/dtc/dtc \
- KERNEL_DTB=`find ${DTBDIR} -type f -name "foundation-v8.dtb"` \
+ KERNEL_DTB="${dtb}" \
IMAGE=img-foundation.axf
make IMAGE=img.axf clean
+ dtb=`find ${DTBDIR} -type f -name "rtsm_ve-aemv8a.dtb"`
./configure --host=aarch64-linux-gnu \
--with-kernel-dir="${B}" \
- --with-cmdline="${BOOTARGS_COMMON} root=/dev/mmcblk0p2"
+ --with-cmdline="${BOOTARGS_COMMON} root=/dev/mmcblk0p2" \
+ --with-dtb="${dtb}"
make DTC=${B}/scripts/dtc/dtc \
- KERNEL_DTB=`find ${DTBDIR} -type f -name "rtsm_ve-aemv8a.dtb"` \
+ KERNEL_DTB="${dtb}" \
IMAGE=img.axf
}