aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-08-08 12:57:59 +0200
committerKoen Kooi <koen.kooi@linaro.org>2014-08-08 12:58:27 +0200
commit5d7cdcb35524fecabde4fae01b1672b2ed0728fd (patch)
tree4dc99c28fd99f96bb336026da5606be27524700b /meta-linaro/recipes-kernel
parent092d9b7c45e08d8363d5f98a19af119966132cf3 (diff)
gator: also use OE CXXFLAGS
This fixes the armv7a build. Change-Id: Id36a544da61f492bb682645a4e657f09c762371b Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 2e3748a8..5e5d6979 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -15,7 +15,8 @@ S = "${WORKDIR}/git"
inherit update-rc.d
EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"' \
- 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
+ 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
+ 'CXXFLAGS=${CXXFLAGS} ${TARGET_CC_ARCH} -fno-rtti'"
do_compile() {
# The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.