aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2014-05-15 19:03:49 +0300
committerFathi Boudra <fathi.boudra@linaro.org>2014-05-15 19:03:49 +0300
commit45207b167e2f2adfcfdcb29579f559b0df7a9b13 (patch)
tree35d7ef7c2296a95751100745d54555f3f43c0dbc /meta-linaro/recipes-kernel
parent432bad4e344fcd8be0340055de7585d391614d16 (diff)
gator: fix build failure gnu/stubs-soft.h: No such file or directory
Pass TARGET_CC_ARCH which will set --sysroot and -mfloat-abi for us. It fixes also gatord stripping and let OE handle it. Change-Id: I1e095ea07b4297a1c7fed76ead8a14e7f6d87721 Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 9982b2bc..748a81c7 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -12,10 +12,11 @@ S = "${WORKDIR}/git"
inherit update-rc.d
+EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"' \
+ 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
+
do_compile() {
- cd daemon
- # aarch64 makefile will work just fine for any arch
- make -f Makefile_aarch64 CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}
+ oe_runmake -C daemon
}
do_install() {