aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel/gator/gator_git.bb
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2013-11-29 17:44:04 +0200
committerRiku Voipio <riku.voipio@linaro.org>2013-11-29 17:45:40 +0200
commitf1a127ef4cd649e91161f64e6a4ddb1585a92342 (patch)
treeb46c7eda5e29860bdab9a9853dde79afc7366e90 /meta-linaro/recipes-kernel/gator/gator_git.bb
parentbb3ad4ae7725ac10c56eb4d79f37bd442000d5f9 (diff)
gator: add initscript
Add automatic start of gatord, help closing https://bugs.launchpad.net/linaro-oe/+bug/1244104 https://bugs.launchpad.net/linaro-oe/+bug/1243688 Change-Id: I8c7a18d58e324c8fbfaaf11579d7677c215b771d Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-kernel/gator/gator_git.bb')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 6e15d441..8aed22f9 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -4,7 +4,10 @@ SUMMARY = "DS-5 Gator daemon"
LICENSE = "GPL-2"
LIC_FILES_CHKSUM = "file://driver/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "git://git.linaro.org/arm/ds5/gator.git"
+inherit update-rc.d
+
+SRC_URI = "git://git.linaro.org/arm/ds5/gator.git \
+ file://gator.init "
SRCREV = "${AUTOREV}"
@@ -20,5 +23,11 @@ do_compile() {
}
do_install() {
- install -D -p -m0755 daemon/gatord ${D}/${sbindir}/gatord
+ install -D -p -m0755 daemon/gatord ${D}/${sbindir}/gatord
+ install -D -p -m0755 ${WORKDIR}/gator.init ${D}/${sysconfdir}/init.d/gator
+
}
+
+INITSCRIPT_NAME = "gator"
+INITSCRIPT_PARAMS = "defaults 66"
+