aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel/gator/gator_git.bb
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2013-10-14 17:06:33 +0300
committerLinaro Code Review <review@review.linaro.org>2013-10-15 06:00:40 +0000
commit730a1bf373ebcb28135f7af806650f0e2bd6a1e4 (patch)
treec69751284e55dfdf1dd0b78c78ccddc3793a6cee /meta-linaro/recipes-kernel/gator/gator_git.bb
parent7eb1afc757e46a1f0d18707a5cf3207483fa815e (diff)
linaro-image-lamp: add gator
add gator to the lamp image, fixes https://bugs.launchpad.net/linaro-oe/+bug/1239282 We also need to fix build on Aarch64, which is just due to useless arch specific settings. Fortunately there is a more generic Makefile in the sources we can use instead. Change-Id: I9422fe4dfe532c8ccb9086f4f78e2ff9155658b0 Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-kernel/gator/gator_git.bb')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 113f1334..6e15d441 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -15,7 +15,8 @@ PR = "r1"
do_compile() {
cd daemon
- make CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}
+ # aarch64 makefile will work just fine for any arch
+ make -f Makefile_aarch64 CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}
}
do_install() {