aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra
diff options
context:
space:
mode:
authorAndrew McDermott <andrew.mcdermott@linaro.org>2013-08-06 19:09:39 +0100
committerAndrew McDermott <andrew.mcdermott@linaro.org>2013-08-06 19:09:39 +0100
commitc4eeb9d314440962c8d732468dfac2f9360918b1 (patch)
tree0b5d4530e1629e1efbe21e8b05909809623edf4e /meta-linaro/recipes-extra
parentf271bbea8e5e1c8714501dc3e1010fc71c9cbf6f (diff)
meta-linaro: acpica: fix parallel build
The compilation of the iasl utility fails when `make -j<N>' > 1. This commit cleans up the rules in generate/unix/iasl such that a `make -j' will succeed. Signed-off-by: Andrew McDermott <andrew.mcdermott@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-extra')
-rw-r--r--meta-linaro/recipes-extra/acpica/acpica_20130626.bb3
-rw-r--r--meta-linaro/recipes-extra/acpica/files/fix-parallel-build.patch80
2 files changed, 82 insertions, 1 deletions
diff --git a/meta-linaro/recipes-extra/acpica/acpica_20130626.bb b/meta-linaro/recipes-extra/acpica/acpica_20130626.bb
index 230ab4da..58d7c4bb 100644
--- a/meta-linaro/recipes-extra/acpica/acpica_20130626.bb
+++ b/meta-linaro/recipes-extra/acpica/acpica_20130626.bb
@@ -24,7 +24,8 @@ SRC_URI="git://git.linaro.org/people/ahs3/acpica-tools.git \
file://name-miscompare.patch \
file://aapits-linux.patch \
file://cross-compile.patch \
- file://no-werror.patch"
+ file://no-werror.patch \
+ file://fix-parallel-build.patch"
SRCREV = "${AUTOREV}"
diff --git a/meta-linaro/recipes-extra/acpica/files/fix-parallel-build.patch b/meta-linaro/recipes-extra/acpica/files/fix-parallel-build.patch
new file mode 100644
index 00000000..42e3fb14
--- /dev/null
+++ b/meta-linaro/recipes-extra/acpica/files/fix-parallel-build.patch
@@ -0,0 +1,80 @@
+diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile
+index e9520ed..1b73d7a 100644
+--- a/generate/unix/iasl/Makefile
++++ b/generate/unix/iasl/Makefile
+@@ -212,13 +212,10 @@ INTERMEDIATES = \
+ MISC = \
+ $(OBJDIR)/aslcompilerparse.h\
+ $(OBJDIR)/aslcompiler.y.h\
+- $(OBJDIR)/aslcompilerparse.output\
+ $(OBJDIR)/dtparserparse.h\
+ $(OBJDIR)/dtparser.y.h\
+- $(OBJDIR)/dtparserparse.output\
+ $(OBJDIR)/prparserparse.h\
+- $(OBJDIR)/prparser.y.h\
+- $(OBJDIR)/prparserparse.output
++ $(OBJDIR)/prparser.y.h
+
+ #
+ # Flags specific to iASL compiler
+@@ -240,21 +237,29 @@ include ../Makefile.rules
+ $(OBJDIR)/aslcompilerlex.c : $(ASL_COMPILER)/aslcompiler.l $(ASL_COMPILER)/aslsupport.l
+ $(LEX) $(LFLAGS) -PAslCompiler -o$@ $(ASL_COMPILER)/aslcompiler.l
+
+-$(OBJDIR)/aslcompilerparse.c $(OBJDIR)/aslcompilerparse.h : $(ASL_COMPILER)/aslcompiler.y
++$(OBJDIR)/aslcompilerparse.c : $(ASL_COMPILER)/aslcompiler.y
+ $(YACC) $(YFLAGS) -pAslCompiler -o$@ $?
+
+ $(OBJDIR)/dtparserlex.c : $(ASL_COMPILER)/dtparser.l
+ $(LEX) $(LFLAGS) -PDtParser -o$@ $?
+
+-$(OBJDIR)/dtparserparse.c $(OBJDIR)/dtparserparse.h : $(ASL_COMPILER)/dtparser.y
++$(OBJDIR)/dtparserparse.c : $(ASL_COMPILER)/dtparser.y
+ $(YACC) $(YFLAGS) -pDtParser -o$@ $?
+
+ $(OBJDIR)/prparserlex.c : $(ASL_COMPILER)/prparser.l
+ $(LEX) $(LFLAGS) -PPrParser -o$@ $?
+
+-$(OBJDIR)/prparserparse.c $(OBJDIR)/prparserparse.h : $(ASL_COMPILER)/prparser.y
++$(OBJDIR)/prparserparse.c : $(ASL_COMPILER)/prparser.y
+ $(YACC) $(YFLAGS) -pPrParser -o$@ $?
+
++$(OBJDIR)/aslcompilerparse.h : $(OBJDIR)/aslcompilerparse.c
++ touch $@
++
++$(OBJDIR)/dtparserparse.h : $(OBJDIR)/dtparserparse.c
++ touch $@
++
++$(OBJDIR)/prparserparse.h: $(OBJDIR)/prparserparse.c
++ touch $@
+
+ #
+ # Rename the headers produced by bison/yacc
+@@ -279,19 +284,21 @@ $(OBJDIR)/prparser.y.h: $(OBJDIR)/prparserparse.h
+ # by the utilities above and they are not necessarily ANSI C, etc.
+ #
+ $(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
+- $(CC) -c $(CFLAGS) -Wall -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
+- $(CC) -c $(CFLAGS) -Wall -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
++
++$(OBJECTS): $(HEADERS)