aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2013-10-10 13:23:39 +0200
committerAnders Roxell <anders.roxell@linaro.org>2013-10-11 08:46:28 +0200
commit02fa3d724d2da91c93d492878e3b86f38435b536 (patch)
tree38ac57292a89c5c479e43de8226fb3fe6686c462 /meta-linaro/recipes-extra
parent763857dd1f91ff911ad343e78848837e21aa96c8 (diff)
trinity: change to patches that got submitted upstream
Change-Id: I55ba5b202b2dcc3e93a45ce93ddc4b438123e05a Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-extra')
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch2
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch2
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0003-scripts-arch-dependent-to-get-the-syscall_list.patch103
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch95
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch2
-rw-r--r--meta-linaro/recipes-extra/trinity/trinity_1.2.bb2
6 files changed, 102 insertions, 104 deletions
diff --git a/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch b/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch
index 4ac04dc3..851a18e6 100644
--- a/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch
+++ b/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch
@@ -5,6 +5,8 @@ Subject: [PATCH 1/3] scripts: TRINITY_PATH defaults to "."
TRINITY_PATH may be changed in the enviroment
+Upstream-Status: Backport
+
Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
---
scripts/analyse-dumps.sh | 4 +++-
diff --git a/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch b/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch
index 485ade76..a0c10956 100644
--- a/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch
+++ b/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch
@@ -3,6 +3,8 @@ From: Anders Roxell <anders.roxell@linaro.org>
Date: Tue, 8 Oct 2013 16:45:08 +0200
Subject: [PATCH 2/3] scripts: change mkdir tmp to mktemp
+Upstream-Status: Accepted
+
Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
---
scripts/find.sh | 10 ++++------
diff --git a/meta-linaro/recipes-extra/trinity/files/0003-scripts-arch-dependent-to-get-the-syscall_list.patch b/meta-linaro/recipes-extra/trinity/files/0003-scripts-arch-dependent-to-get-the-syscall_list.patch
deleted file mode 100644
index 52be5824..00000000
--- a/meta-linaro/recipes-extra/trinity/files/0003-scripts-arch-dependent-to-get-the-syscall_list.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-From b28f02ef2bf5098a43167a8c48dbcb853cd7d03a Mon Sep 17 00:00:00 2001
-From: Anders Roxell <anders.roxell@linaro.org>
-Date: Tue, 8 Oct 2013 22:26:51 +0200
-Subject: [PATCH 3/3] scripts: arch dependent to get the syscall_list
-
-ARCH may be changed in the enviroment
-
-Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
----
- scripts/find.sh | 11 ++++++++++-
- scripts/test-all-syscalls-parallel.sh | 11 ++++++++++-
- scripts/test-all-syscalls-sequentially.sh | 11 ++++++++++-
- 3 files changed, 30 insertions(+), 3 deletions(-)
-
-diff --git a/scripts/find.sh b/scripts/find.sh
-index 3f10c58..2687918 100755
---- a/scripts/find.sh
-+++ b/scripts/find.sh
-@@ -7,6 +7,15 @@
-
- TRINITY_PATH=${TRINITY_PATH:-.}
- TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-+ARCH=${ARCH:-x86}
-+
-+$TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | \
-+ awk '{ print $4 }' | sort -u> $TRINITY_TMP/syscall_list
-+
-+if [ $ARCH = "arm" ]; then
-+ $TRINITY_PATH/trinity -L | grep -v AVOID | \
-+ awk '{ print $2 }' | sort -u> $TRINITY_TMP/syscall_list
-+fi
-
- check_tainted()
- {
-@@ -27,7 +36,7 @@ while [ 1 ];
- do
-
-
--for sc in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+for sc in $(cat $TRINITY_TMP/syscall_list)
- do
- mkdir -p tmp.$i
- pushd tmp.$i
-diff --git a/scripts/test-all-syscalls-parallel.sh b/scripts/test-all-syscalls-parallel.sh
-index 312fd2a..9c19f64 100755
---- a/scripts/test-all-syscalls-parallel.sh
-+++ b/scripts/test-all-syscalls-parallel.sh
-@@ -2,13 +2,22 @@
-
- TRINITY_PATH=${TRINITY_PATH:-.}
- TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-+ARCH=${ARCH:-x86}
-+
-+$TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | \
-+ awk '{ print $4 }' | sort -u> $TRINITY_TMP/syscall_list
-+
-+if [ $ARCH = "arm" ]; then
-+ $TRINITY_PATH/trinity -L | grep -v AVOID | \
-+ awk '{ print $2 }' | sort -u> $TRINITY_TMP/syscall_list
-+fi
-
- chmod 755 $TRINITY_TMP
- cd $TRINITY_TMP
-
- while [ 1 ];
- do
-- for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+ for syscall in $(cat $TRINITY_TMP/syscall_list)
- do
- MALLOC_CHECK_=2 $TRINITY_PATH/trinity -q -c $syscall -D &
- done
-diff --git a/scripts/test-all-syscalls-sequentially.sh b/scripts/test-all-syscalls-sequentially.sh
-index 2b726fc..3eea70a 100755
---- a/scripts/test-all-syscalls-sequentially.sh
-+++ b/scripts/test-all-syscalls-sequentially.sh
-@@ -5,6 +5,15 @@
-
- TRINITY_PATH=${TRINITY_PATH:-.}
- TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-+ARCH=${ARCH:-x86}
-+
-+$TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | \
-+ awk '{ print $4 }' | sort -u> $TRINITY_TMP/syscall_list
-+
-+if [ $ARCH = "arm" ]; then
-+ $TRINITY_PATH/trinity -L | grep -v AVOID | \
-+ awk '{ print $2 }' | sort -u> $TRINITY_TMP/syscall_list
-+fi
-
- check_tainted()
- {
-@@ -18,7 +27,7 @@ TAINT=$(cat /proc/sys/kernel/tainted)
-
- while [ 1 ]
- do
--for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+for syscall in $(cat $TRINITY_TMP/syscall_list)
- do
- chmod 755 $TRINITY_TMP
- pushd $TRINITY_TMP
---
-1.8.1.2
-
diff --git a/meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch b/meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch
new file mode 100644
index 00000000..bc5a4831
--- /dev/null
+++ b/meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch
@@ -0,0 +1,95 @@
+From 2bddde3a834bd19a6e72761b98ad2e57956af42e Mon Sep 17 00:00:00 2001
+From: Anders Roxell <anders.roxell@linaro.org>
+Date: Thu, 10 Oct 2013 09:46:01 +0200
+Subject: [PATCH 3/4] tables.c: change the output format of -L
+
+So the scripts can works for both biarch and !biarch
+
+Upstream-Status: Backport
+
+Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
+---
+ scripts/find.sh | 2 +-
+ scripts/test-all-syscalls-parallel.sh | 2 +-
+ scripts/test-all-syscalls-sequentially.sh | 2 +-
+ tables.c | 10 +++++-----
+ 4 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/scripts/find.sh b/scripts/find.sh
+index 3f10c58..4c970c1 100755
+--- a/scripts/find.sh
++++ b/scripts/find.sh
+@@ -27,7 +27,7 @@ while [ 1 ];
+ do
+
+
+-for sc in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
++for sc in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $3 }' | sort -u)
+ do
+ mkdir -p tmp.$i
+ pushd tmp.$i
+diff --git a/scripts/test-all-syscalls-parallel.sh b/scripts/test-all-syscalls-parallel.sh
+index 312fd2a..7206364 100755
+--- a/scripts/test-all-syscalls-parallel.sh
++++ b/scripts/test-all-syscalls-parallel.sh
+@@ -8,7 +8,7 @@ cd $TRINITY_TMP
+
+ while [ 1 ];
+ do
+- for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
++ for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $3 }' | sort -u)
+ do
+ MALLOC_CHECK_=2 $TRINITY_PATH/trinity -q -c $syscall -D &
+ done
+diff --git a/scripts/test-all-syscalls-sequentially.sh b/scripts/test-all-syscalls-sequentially.sh
+index 2b726fc..14fb4c3 100755
+--- a/scripts/test-all-syscalls-sequentially.sh
++++ b/scripts/test-all-syscalls-sequentially.sh
+@@ -18,7 +18,7 @@ TAINT=$(cat /proc/sys/kernel/tainted)
+
+ while [ 1 ]
+ do
+-for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
++for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $3 }' | sort -u)
+ do
+ chmod 755 $TRINITY_TMP
+ pushd $TRINITY_TMP
+diff --git a/tables.c b/tables.c
+index d12b541..39c49f9 100644
+--- a/tables.c
++++ b/tables.c
+@@ -411,18 +411,18 @@ void dump_syscall_tables(void)
+ unsigned int i;
+
+ if (biarch == TRUE) {
+- printf("32-bit syscalls: %d\n", max_nr_32bit_syscalls);
+- printf("64-bit syscalls: %d\n", max_nr_64bit_syscalls);
++ printf("syscalls: %d [32-bit] \n", max_nr_32bit_syscalls);
++ printf("syscalls: %d [64-bit] \n", max_nr_64bit_syscalls);
+
+ for_each_32bit_syscall(i) {
+- printf("32-bit entrypoint %d %s : ", syscalls_32bit[i].entry->number, syscalls_32bit[i].entry->name);
++ printf("entrypoint %d %s : [32-bit] ", syscalls_32bit[i].entry->number, syscalls_32bit[i].entry->name);
+ show_state(syscalls_32bit[i].entry->flags & ACTIVE);
+ if (syscalls_32bit[i].entry->flags & AVOID_SYSCALL)
+ printf(" AVOID");
+ printf("\n");
+ }
+ for_each_64bit_syscall(i) {
+- printf("64-bit entrypoint %d %s : ", syscalls_64bit[i].entry->number, syscalls_64bit[i].entry->name);
++ printf("entrypoint %d %s : [64-bit] ", syscalls_64bit[i].entry->number, syscalls_64bit[i].entry->name);
+ show_state(syscalls_64bit[i].entry->flags & ACTIVE);
+ if (syscalls_64bit[i].entry->flags & AVOID_SYSCALL)
+ printf(" AVOID");
+@@ -431,7 +431,7 @@ void dump_syscall_tables(void)
+ } else {
+ printf("syscalls: %d\n", max_nr_syscalls);
+ for_each_syscall(i) {
+- printf("%d %s : ", syscalls[i].entry->number, syscalls[i].entry->name);
++ printf("entrypoint %d %s : ", syscalls[i].entry->number, syscalls[i].entry->name);
+ show_state(syscalls[i].entry->flags & ACTIVE);
+ if (syscalls[i].entry->flags & AVOID_SYSCALL)
+ printf(" AVOID");
+--
+1.8.1.2
+
diff --git a/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch b/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch
index dd9dad9a..7654ef75 100644
--- a/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch
+++ b/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch
@@ -6,6 +6,8 @@ Subject: [PATCH 4/4] add support for the AArch64 architecture
This patch wires up support for the AArch64 architecture, which has been
supported in the mainline kernel (as arm64) since 3.7.
+Upstream-Status: Backport
+
Signed-off-by: Will Deacon <will.deacon@arm.com>
---
include/arch-aarch64.h | 13 +++
diff --git a/meta-linaro/recipes-extra/trinity/trinity_1.2.bb b/meta-linaro/recipes-extra/trinity/trinity_1.2.bb
index d760c168..0f248d42 100644
--- a/meta-linaro/recipes-extra/trinity/trinity_1.2.bb
+++ b/meta-linaro/recipes-extra/trinity/trinity_1.2.bb
@@ -9,7 +9,7 @@ COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
SRC_URI = "http://codemonkey.org.uk/projects/trinity/trinity-${PV}.tgz \
file://0001-scripts-TRINITY_PATH-defaults-to.patch \
file://0002-scripts-change-mkdir-tmp-to-mktemp.patch \
- file://0003-scripts-arch-dependent-to-get-the-syscall_list.patch \
+ file://0003-tables.c-change-the-output-format-of-L.patch \
file://0004-add-support-for-the-AArch64-architecture.patch \
"