aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra/odp/odp.bb
diff options
context:
space:
mode:
authorGary S. Robertson <gary.robertson@linaro.org>2015-03-04 12:50:19 -0600
committerFathi Boudra <fathi.boudra@linaro.org>2015-03-09 16:37:35 +0000
commit2f97e447a01f8ae4c47757a9cb6d743df36ab378 (patch)
tree4375c3adf3ec08e45ba5cc40876e3e92c282bd8f /meta-linaro/recipes-extra/odp/odp.bb
parent240f05bca079801bb491a355607b340c440dd3db (diff)
odp: update recipe to use Release 1.0 source
Patch 1 of 2 Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> odp: fix compiler warning/error re. use of _BSD_SOURCE Patch 2 of 2 This patch allows compilation of the ODP v1.0 sources to complete. It is added to the OE recipe for odp since that recipe is pinned to ODP release version 1.0, which requires the patch. Details of the problem are found in the patch file itself and in Linaro BUG #1312 Upstream status: The patch added here has been accepted into the upstream ODP repository, but is nonetheless still required for this recipe since the source revision upon which the recipe is based lacks the patch. Change-Id: I678d84a418473cd47b8503603b1320806be24db0 Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-extra/odp/odp.bb')
-rw-r--r--meta-linaro/recipes-extra/odp/odp.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-linaro/recipes-extra/odp/odp.bb b/meta-linaro/recipes-extra/odp/odp.bb
index c62f4dc3..4b5dd1ae 100644
--- a/meta-linaro/recipes-extra/odp/odp.bb
+++ b/meta-linaro/recipes-extra/odp/odp.bb
@@ -9,9 +9,11 @@ PV = "20140820+git${SRCPV}"
DEPENDS = "openssl"
-SRC_URI = "git://git.linaro.org/lng/odp.git;name=odp"
+SRC_URI = "git://git.linaro.org/lng/odp.git;name=odp \
+ file://0001-Replace-deprecated-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch \
+"
-SRCREV_odp = "26238333b5b0896366c844aeb7253e60abd99f5a"
+SRCREV_odp = "49bc9ee8fdd47c6193108a90c94ca3b3de66ba46"
SRCREV_FORMAT = "odp"
S = "${WORKDIR}/git"
@@ -20,5 +22,11 @@ inherit autotools
RDEPENDS_${PN} = "libcrypto"
+#PACKAGECONFIG ?= ""
+#PACKAGECONFIG[vald] = "--enable-test-vald,,,"
+#PACKAGECONFIG[perf] = "--enable-test-perf,,,"
+#PACKAGECONFIG[cunit] = "--enable-cunit,,cunit,cunit"
+#PACKAGECONFIG[cunit] = "--with-cunit-path=DIR,,cunit,"
+
# ODP primary shipped as static library plus some API test and samples/
FILES_${PN}-staticdev += "${datadir}/opendataplane/*.la"