aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-05-09 18:32:34 +0200
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-05-09 18:32:34 +0200
commit76d9f005ffcd6e8a8500efea38b508e440b344f0 (patch)
tree77bde05b436472f1437d876add1ddc1516cb789e /meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch
parent6a9ddcafc7169a829ed64810f1f47824eee7a1f3 (diff)
gdb: add 7.6 (on a way to OE Core)
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch')
-rw-r--r--meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch b/meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch
new file mode 100644
index 00000000..a663ba7b
--- /dev/null
+++ b/meta-linaro/recipes-devtools/gdb/gdb/sim-install.patch
@@ -0,0 +1,36 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+--- gdb-6.1/sim/common/Makefile.in~ 2004-01-15 21:25:06.000000000 +0000
++++ gdb-6.1/sim/common/Makefile.in 2004-07-22 17:07:46.237809032 +0100
+@@ -34,7 +34,7 @@
+
+ datadir = @datadir@
+ mandir = @mandir@
+-man1dir = $(mandir)/man1
++man1dir = $(DESTDIR)$(mandir)/man1
+ infodir = @infodir@
+ includedir = @includedir@
+
+
+--- gdb-6.1/sim/common/Make-common.in~sim-install.patch 2003-09-08 18:24:59.000000000 +0100
++++ gdb-6.1/sim/common/Make-common.in 2004-07-22 17:56:18.947423032 +0100
+@@ -581,14 +581,14 @@
+
+ install-common: installdirs
+ n=`echo run | sed '$(program_transform_name)'`; \
+- $(INSTALL_PROGRAM) run$(EXEEXT) $(bindir)/$$n$(EXEEXT)
++ $(INSTALL_PROGRAM) run$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT)
+ n=`echo libsim.a | sed s/libsim.a/lib$(target_alias)-sim.a/`; \
+- $(INSTALL_DATA) libsim.a $(libdir)/$$n ; \
+- ( cd $(libdir) ; $(RANLIB) $$n )
++ $(INSTALL_DATA) libsim.a $(DESTDIR)$(libdir)/$$n ; \
++ ( cd $(DESTDIR)$(libdir) ; $(RANLIB) $$n )
+
+ installdirs:
+- $(SHELL) $(srcdir)/../../mkinstalldirs $(bindir)
+- $(SHELL) $(srcdir)/../../mkinstalldirs $(libdir)
++ $(SHELL) $(srcdir)/../../mkinstalldirs $(DESTDIR)$(bindir)
++ $(SHELL) $(srcdir)/../../mkinstalldirs $(DESTDIR)$(libdir)
+
+ check:
+ cd ../testsuite && $(MAKE) check RUNTESTFLAGS="$(RUNTESTFLAGS)"