aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-08-10 10:36:44 +0200
committerFathi Boudra <fathi.boudra@linaro.org>2014-08-10 08:38:28 +0000
commit4a063d9bd1b1827f21837c0f887966a931963b35 (patch)
tree06343706e4604b24964ddf10d003e3187441d782 /meta-aarch64
parentfa806f829f299395d664f137d5bef4685312cd6a (diff)
qt4-x11-free 4.8.6 bbappend: update patch
OE-core added mips64 support which clashes with our armv8 support. This fixes: ERROR: Command Error: exit status: 1 Output: Applying patch aarch64.patch patching file src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h Hunk #1 succeeded at 371 (offset 4 lines). Hunk #2 FAILED at 1001. 1 out of 2 hunks FAILED -- rejects in file src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h Patch aarch64.patch does not apply (enforce with -f) ERROR: Function failed: patch_do_patch ERROR: Logfile of failure stored in: /build/scratch/angstrom-v2014.12/build/tmp-angstrom_next-eglibc/work/armv7at2hf-vfp-angstrom-linux-gnueabi/qt4-x11-free/4.8.6-r0/temp/log.do_patch.21352 ERROR: Task 1 (/build/scratch/angstrom-v2014.12/sources/openembedded-core/meta/recipes-qt/qt4/qt4-x11-free_4.8.6.bb, do_patch) failed with exit code '1' Change-Id: I155749907835df33d432d87340e81efd0ef234d6 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-aarch64')
-rw-r--r--meta-aarch64/recipes-qt/qt4/files/aarch64.patch35
1 files changed, 19 insertions, 16 deletions
diff --git a/meta-aarch64/recipes-qt/qt4/files/aarch64.patch b/meta-aarch64/recipes-qt/qt4/files/aarch64.patch
index 7ad10341..2c970fe0 100644
--- a/meta-aarch64/recipes-qt/qt4/files/aarch64.patch
+++ b/meta-aarch64/recipes-qt/qt4/files/aarch64.patch
@@ -1,12 +1,18 @@
+From d780ac54b5dd1cf45eb59103f014f811c407d38c Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sun, 10 Aug 2014 10:35:33 +0200
+Subject: [PATCH] JavaScriptCore: add Aarch64 support
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
---
- src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h | 8 +++++++-
+ src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
---- qt-everywhere-opensource-src-4.8.4.orig/src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h
-+++ qt-everywhere-opensource-src-4.8.4/src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h
-@@ -367,10 +367,15 @@
-
- #if CPU(ARM) || CPU(MIPS) || CPU(SH4)
+diff --git a/src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h b/src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h
+index e8b03be..01a839f 100644
+--- a/src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h
++++ b/src/3rdparty/webkit/Source/JavaScriptCore/wtf/Platform.h
+@@ -373,6 +373,11 @@
#define WTF_CPU_NEEDS_ALIGNED_ACCESS 1
#endif
@@ -18,19 +24,16 @@
/* ==== OS() - underlying operating system; only to be used for mandated low-level services like
virtual memory, not to choose a GUI toolkit ==== */
- /* OS(ANDROID) - Android */
- #ifdef ANDROID
-@@ -996,11 +1001,12 @@
- #if (CPU(X86_64) && (OS(UNIX) || OS(WINDOWS))) \
- || (CPU(IA64) && !CPU(IA64_32)) \
- || CPU(ALPHA) \
+@@ -1003,7 +1008,8 @@
|| CPU(SPARC64) \
|| CPU(S390X) \
-- || CPU(PPC64)
-+ || CPU(PPC64) \
+ || CPU(PPC64) \
+- || CPU(MIPS64)
++ || CPU(MIPS64) \
+ || CPU(AARCH64)
#define WTF_USE_JSVALUE64 1
#else
#define WTF_USE_JSVALUE32_64 1
- #endif
- #endif /* !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32_64) */
+--
+1.9.0
+