aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2013-09-05 09:30:29 +0200
committerFathi Boudra <fathi.boudra@linaro.org>2013-09-05 21:34:24 +0300
commitfd138c2ff0833ce9799fd240501e57d0ea3dd9e3 (patch)
tree684e4a71abcf7453267dd23e2f4b067170e02886 /meta-aarch64
parent12ca634aa4313d9a55d3de6189446dc55ca32363 (diff)
ltp: fix so LTP and LTP-realtime works
Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Acked-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-aarch64')
-rw-r--r--meta-aarch64/recipes-extended/ltp/files/0002-realtime-parser-remove-unused-and-depricated-imports.patch28
-rw-r--r--meta-aarch64/recipes-extended/ltp/files/0003-runltp-rework-echo-n-to-printf-POSIX-compliant.patch62
-rw-r--r--meta-aarch64/recipes-extended/ltp/ltp_20130503.bbappend3
3 files changed, 93 insertions, 0 deletions
diff --git a/meta-aarch64/recipes-extended/ltp/files/0002-realtime-parser-remove-unused-and-depricated-imports.patch b/meta-aarch64/recipes-extended/ltp/files/0002-realtime-parser-remove-unused-and-depricated-imports.patch
new file mode 100644
index 00000000..77e0f2eb
--- /dev/null
+++ b/meta-aarch64/recipes-extended/ltp/files/0002-realtime-parser-remove-unused-and-depricated-imports.patch
@@ -0,0 +1,28 @@
+From ff3936a916d119d020cc2ab8da22460a34fca612 Mon Sep 17 00:00:00 2001
+From: Anders Roxell <anders.roxell@linaro.org>
+Date: Thu, 29 Aug 2013 15:55:47 +0200
+Subject: [PATCH 2/3] realtime parser: remove unused and depricated imports
+
+Upstream-Status: Upstreamed
+
+Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
+---
+ testcases/realtime/scripts/parser.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testcases/realtime/scripts/parser.py b/testcases/realtime/scripts/parser.py
+index b90233c..6b2dc73 100644
+--- a/testcases/realtime/scripts/parser.py
++++ b/testcases/realtime/scripts/parser.py
+@@ -26,7 +26,7 @@
+ ## ##
+ ################################################################################
+
+-import sys,os,string,re
++import sys
+
+ class Log:
+ def __init__(self,filename):
+--
+1.8.1.2
+
diff --git a/meta-aarch64/recipes-extended/ltp/files/0003-runltp-rework-echo-n-to-printf-POSIX-compliant.patch b/meta-aarch64/recipes-extended/ltp/files/0003-runltp-rework-echo-n-to-printf-POSIX-compliant.patch
new file mode 100644
index 00000000..8140bdd3
--- /dev/null
+++ b/meta-aarch64/recipes-extended/ltp/files/0003-runltp-rework-echo-n-to-printf-POSIX-compliant.patch
@@ -0,0 +1,62 @@
+From 4691f01fd45b333ca2b80212320400d07d861432 Mon Sep 17 00:00:00 2001
+From: Anders Roxell <anders.roxell@linaro.org>
+Date: Tue, 3 Sep 2013 09:42:35 +0200
+Subject: [PATCH 3/3] runltp: rework echo -n to printf POSIX-compliant
+
+Upstream-Status: Upstreamed
+
+Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
+---
+ runltp | 18 ++++++++----------
+ 1 file changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/runltp b/runltp
+index a419bf8..e86f5c7 100755
+--- a/runltp
++++ b/runltp
+@@ -537,18 +537,16 @@ main()
+ {
+ [ -z "$RHOST" ] && \
+ {
+- echo \
+- "INFO: Enter RHOST = 'name of the remote host machine'"
+- echo -n "-> "
++ printf "INFO: Enter RHOST = 'name of the remote host machine'"
++ printf "\n-> "
+ read RHOST
+ }
+
+ [ -z "$PASSWD" ] && \
+ {
+- echo " "
+- echo \
+- "INFO: Enter PASSWD = 'root passwd of the remote host machine'"
+- echo -n "-> "
++ printf "\nINFO: "
++ printf "Enter PASSWD = 'root passwd of the remote host machine'"
++ printf "\n-> "
+ read PASSWD
+ }
+ export RHOST=$RHOST
+@@ -733,15 +731,15 @@ main()
+ #$PAN_COMMAND #Duplicated code here, because otherwise if we fail, only "PAN_COMMAND" gets output
+
+ ## Display the Output/Log/Failed/HTML file names here
+- echo -e "LOG File: \c"
++ printf "LOG File: "
+ echo $LOGFILE | cut -b4-
+
+ if [ "$OUTPUTFILE" ]; then
+- echo -e "OUTPUT File: \c"
++ printf "OUTPUT File: "
+ echo $OUTPUTFILE | cut -b4-
+ fi
+
+- echo -e "FAILED COMMAND File: \c"
++ printf "FAILED COMMAND File: "
+ echo $FAILCMDFILE | cut -b4-
+
+ if [ "$HTMLFILE" ]; then
+--
+1.8.1.2
+
diff --git a/meta-aarch64/recipes-extended/ltp/ltp_20130503.bbappend b/meta-aarch64/recipes-extended/ltp/ltp_20130503.bbappend
index 90f0d872..56eb09cc 100644
--- a/meta-aarch64/recipes-extended/ltp/ltp_20130503.bbappend
+++ b/meta-aarch64/recipes-extended/ltp/ltp_20130503.bbappend
@@ -2,6 +2,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI_append = " file://ltp-arm64.patch \
file://0001-realtime-testsuite-update-the-install-rule.patch \
+ file://0002-realtime-parser-remove-unused-and-depricated-imports.patch \
+ file://0003-runltp-rework-echo-n-to-printf-POSIX-compliant.patch \
"
EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite "
+RDEPENDS_${PN}_append = " e2fsprogs-mke2fs "