aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64
diff options
context:
space:
mode:
authorCiprian Barbu <ciprian.barbu@linaro.org>2014-03-10 14:36:18 +0200
committerCiprian Barbu <ciprian.barbu@linaro.org>2014-03-10 15:54:45 +0200
commit2b9a1e1e14c31b84454e356410dad47767f1a327 (patch)
treec97e6adb02f1ebf3e8b66ca8076f3fde883a3487 /meta-aarch64
parentd3f266d31e6ec2936dafef44a9100b4b5e250729 (diff)
Fix ltp realtime hrtimer-prio and measurement to pass default profile to run_c_files.sh
Change-Id: I1fd669a99abfbdfc59f695830e1a4c43c44eecce Signed-off-by: Ciprian Barbu <ciprian.barbu@linaro.org>
Diffstat (limited to 'meta-aarch64')
-rw-r--r--meta-aarch64/recipes-extended/ltp/files/run-auto-use-default-profile-hrtimer-pro-measurement.patch57
-rw-r--r--meta-aarch64/recipes-extended/ltp/ltp_20140115.bb1
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-aarch64/recipes-extended/ltp/files/run-auto-use-default-profile-hrtimer-pro-measurement.patch b/meta-aarch64/recipes-extended/ltp/files/run-auto-use-default-profile-hrtimer-pro-measurement.patch
new file mode 100644
index 00000000..5a2a4777
--- /dev/null
+++ b/meta-aarch64/recipes-extended/ltp/files/run-auto-use-default-profile-hrtimer-pro-measurement.patch
@@ -0,0 +1,57 @@
+From 389afddcba537e60ca6e46d25199bdb3e716a76a Mon Sep 17 00:00:00 2001
+From: Ciprian Barbu <ciprian.barbu@linaro.org>
+Date: Mon, 10 Mar 2014 13:00:28 +0200
+Subject: [PATCH] Fix ltp realtime hrtimer-prio and measurement to pass
+ default profile to run_c_files.sh
+
+Signed-off-by: Ciprian Barbu <ciprian.barbu@linaro.org>
+
+Upstream-Status: Pending
+---
+ testcases/realtime/func/hrtimer-prio/run_auto.sh | 4 +++-
+ testcases/realtime/func/measurement/run_auto.sh | 6 ++++--
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/testcases/realtime/func/hrtimer-prio/run_auto.sh b/testcases/realtime/func/hrtimer-prio/run_auto.sh
+index 366e746..ec3d83a 100644
+--- a/testcases/realtime/func/hrtimer-prio/run_auto.sh
++++ b/testcases/realtime/func/hrtimer-prio/run_auto.sh
+@@ -1,5 +1,7 @@
+ #! /bin/bash
+
++profile=${1:-default}
++
+ if [ ! $SCRIPTS_DIR ]; then
+ # assume we're running standalone
+ export SCRIPTS_DIR=../../scripts/
+@@ -7,4 +9,4 @@ fi
+
+ source $SCRIPTS_DIR/setenv.sh
+
+-$SCRIPTS_DIR/run_c_files.sh "hrtimer-prio"
++$SCRIPTS_DIR/run_c_files.sh $profile "hrtimer-prio"
+diff --git a/testcases/realtime/func/measurement/run_auto.sh b/testcases/realtime/func/measurement/run_auto.sh
+index 3011964..439f721 100644
+--- a/testcases/realtime/func/measurement/run_auto.sh
++++ b/testcases/realtime/func/measurement/run_auto.sh
+@@ -1,5 +1,7 @@
+ #! /bin/bash
+
++profile=${1:-default}
++
+ if [ ! $SCRIPTS_DIR ]; then
+ # assume we're running standalone
+ export SCRIPTS_DIR=../../scripts/
+@@ -13,7 +15,7 @@ source $SCRIPTS_DIR/setenv.sh
+ # issues right now.
+
+ LOG_FILE="$LOG_DIR/$LOG_FORMAT-rdtsc-latency.log"
+-$SCRIPTS_DIR/run_c_files.sh "rdtsc-latency"
++$SCRIPTS_DIR/run_c_files.sh $profile "rdtsc-latency"
+
+ LOG_FILE="$LOG_DIR/$LOG_FORMAT-preempt_timing.log"
+-$SCRIPTS_DIR/run_c_files.sh "preempt_timing"
++$SCRIPTS_DIR/run_c_files.sh $profile "preempt_timing"
+--
+1.7.9.5
+
diff --git a/meta-aarch64/recipes-extended/ltp/ltp_20140115.bb b/meta-aarch64/recipes-extended/ltp/ltp_20140115.bb
index 6fa3030b..9e55da78 100644
--- a/meta-aarch64/recipes-extended/ltp/ltp_20140115.bb
+++ b/meta-aarch64/recipes-extended/ltp/ltp_20140115.bb
@@ -27,6 +27,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://regen-makefile.patch \
file://ffsb-arm64.patch \
file://ltp-arm64.patch \
+ file://run-auto-use-default-profile-hrtimer-pro-measurement.patch \
"
S = "${WORKDIR}/git"