aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64/recipes-kernel
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2013-05-23 15:22:11 +0300
committerRiku Voipio <riku.voipio@linaro.org>2013-05-24 08:41:36 +0300
commit81c5b8e3cae30e04d4d7bd36c2042470bb3531e1 (patch)
treebdfd213b2482cd43d9be21f12d293356ed789aa5 /meta-aarch64/recipes-kernel
parentc8dd4996d3c66c36d778e29006f99d98eae999e8 (diff)
linux-linaro: fix build with external toolchain
seems like I broke it in the last commit...
Diffstat (limited to 'meta-aarch64/recipes-kernel')
-rw-r--r--meta-aarch64/recipes-kernel/linux/linux-linaro_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-aarch64/recipes-kernel/linux/linux-linaro_git.bb b/meta-aarch64/recipes-kernel/linux/linux-linaro_git.bb
index bee8544d..ba4cfb3e 100644
--- a/meta-aarch64/recipes-kernel/linux/linux-linaro_git.bb
+++ b/meta-aarch64/recipes-kernel/linux/linux-linaro_git.bb
@@ -30,25 +30,26 @@ do_configure_prepend() {
}
do_compile_append() {
+ CROSS=`echo $CC|sed -e s/gcc.*//`
install -m 0644 ${S}/arch/arm64/boot/Image ${BW}/
install -m 0644 ${S}/arch/arm64/boot/dts/*.dts* ${BW}/
cd ${BW}
make clean
make DTC=${S}/scripts/dtc/dtc \
FDT_SRC=foundation-v8.dts \
- CROSS_COMPILE=aarch64-oe-linux- \
+ CROSS_COMPILE=$CROSS \
IMAGE=linux-system-foundation.axf \
BOOTARGS='"${BOOTARGS_COMMON} root=/dev/vda"'
make clean
make DTC=${S}/scripts/dtc/dtc \
FDT_SRC=foundation-v8.dts \
- CROSS_COMPILE=aarch64-oe-linux- \
+ CROSS_COMPILE=$CROSS \
IMAGE=img-foundation.axf \
BOOTARGS='"${BOOTARGS_COMMON} root=/dev/vda2"'
make clean
make DTC=${S}/scripts/dtc/dtc \
FDT_SRC=rtsm_ve-aemv8a.dts \
- CROSS_COMPILE=aarch64-oe-linux- \
+ CROSS_COMPILE=$CROSS \
IMAGE=linux-system-ve.axf \
BOOTARGS='"${BOOTARGS_COMMON} root=/dev/mmcblk0"'
}