aboutsummaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorKen Werner <ken.werner@linaro.org>2012-02-16 12:30:07 +0100
committerKen Werner <ken.werner@linaro.org>2012-03-07 14:23:06 +0100
commitd8a889c9b9db14ce30e43534bfa197e5bd7d041e (patch)
tree5e0f321aba08de62e46735a65485b74db1de4ac2 /conf
parent4c632080e5bf3061111a2a0a0a131951c861c177 (diff)
Add support for the Linaro 3.1 kernel
Allows to build the git.linaro.org/kernel/linux-linaro-3.1.git kernel sources using a vexpress defconfig. Signed-off-by: Ken Werner <ken.werner@linaro.org>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf11
1 files changed, 10 insertions, 1 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 060e2b02..7f869dd1 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,3 +1,12 @@
BBPATH .= ":${LAYERDIR}"
BBFILES .= "${LAYERDIR}/recipes-*/*.bb \
- ${LAYERDIR}/recipes-*/*.bbappend"
+ ${LAYERDIR}/recipes-*/*.bbappend \
+ ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "linaro"
+BBFILE_PATTERN_linaro := "^${LAYERDIR}/"
+BBFILE_PRIORITY_linaro = "5"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-linaro"
+PREFERRED_PROVIDER_kernel-base = "linux-linaro"