aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2020-02-03 23:25:01 +0100
committerPeter Griffin <peter.griffin@linaro.org>2020-02-03 23:26:33 +0100
commit4eb4ec96478ef6cf762e2196bef090e900baa4e9 (patch)
tree57cb82e3ac626cc381e254b53ceed3166c661ac7
parentc0f537e7c58c78d293cfb008733bba4394342807 (diff)
python-pycrypto: remove python-pycrypto recipe
As we can just use the standard package in meta-openembedded. Signed-off-by: Peter Griffin <peter.griffin@linaro.org> Change-Id: I381645c5663c5299d6c9e7d47451afc1cc2c9ac5
-rw-r--r--meta-optee/recipes-devtools/python/python-pycrypto/cross-compiling.patch23
-rw-r--r--meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb34
2 files changed, 0 insertions, 57 deletions
diff --git a/meta-optee/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-optee/recipes-devtools/python/python-pycrypto/cross-compiling.patch
deleted file mode 100644
index 712f3e8d..00000000
--- a/meta-optee/recipes-devtools/python/python-pycrypto/cross-compiling.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: pycrypto-2.6/setup.py
-===================================================================
---- pycrypto-2.6.orig/setup.py
-+++ pycrypto-2.6/setup.py
-@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
- if not os.path.exists("config.status"):
- if os.system("chmod 0755 configure") != 0:
- raise RuntimeError("chmod error")
-- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
-+ host = os.environ.get("HOST_SYS")
-+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
- if self.verbose < 1:
- cmd += " -q"
- if os.system(cmd) != 0:
-@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
- 'ext_modules': plat_ext + [
- # _fastmath (uses GNU mp library)
- Extension("Crypto.PublicKey._fastmath",
-- include_dirs=['src/','/usr/include/'],
-+ include_dirs=['src/'],
- libraries=['gmp'],
- sources=["src/_fastmath.c"]),
-
diff --git a/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb
deleted file mode 100644
index 1477418d..00000000
--- a/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "Cryptographic modules for Python."
-HOMEPAGE = "http://www.pycrypto.org/"
-SECTION = "devel/python"
-LICENSE = "PSFv2"
-LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
-
-SRCNAME = "pycrypto"
-
-SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
- file://cross-compiling.patch"
-
-SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
-SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit autotools autotools-brokensep distutils
-
-DEPENDS += " gmp"
-
-export STAGING_INCDIR
-export STAGING_LIBDIR
-export BUILD_SYS
-export HOST_SYS
-
-
-# We explicitly call distutils_do_install, since we want it to run, but
-# *don't* want the autotools install to run, since this package doesn't
-# provide a "make install" target.
-do_install() {
- distutils_do_install
-}
-
-BBCLASSEXTEND = "native"