aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2017-11-23 10:20:40 +0100
committerFathi Boudra <fathi.boudra@linaro.org>2017-12-07 10:22:36 +0000
commit259b8bfbb5dc13a4173f9e90bdf09f5aebea473e (patch)
treec1cd5c39c38ea3e9515d9f19827fd825a0053a36
parent9deba4e8dd95a97857182919ac1280b163681c15 (diff)
optee-os: simplify deploy logic
The complicated logic forces recipes to hardcode the SRCREVs in downstream recipes, leading to sync issues. Change-Id: I72363339ea48ed61b6b9f113814a8f71918c1f62 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb15
1 files changed, 4 insertions, 11 deletions
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index a6a62d57..4f6be1ef 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -53,17 +53,10 @@ do_install() {
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_deploy() {
- long_srvrev=${SRCREV}
- short_srvrev=$(echo $long_srvrev | awk '{ string=substr($0, 1, 8); print string; }' )
- OPTEE_CORE_SUFFIX="${MACHINE}-$short_srvrev"
- install -d ${DEPLOYDIR}/optee
- for f in ${D}/lib/firmware/*; do
- filename=$(basename "$f")
- extension="${filename##*.}"
- sfilename="${filename%.*}"
- bbnote "Deploy $sfilename-${OPTEE_CORE_SUFFIX}.$extension"
- install -m 644 $f ${DEPLOYDIR}/optee/$sfilename-${OPTEE_CORE_SUFFIX}.$extension
- done
+ install -d ${DEPLOYDIR}/optee
+ for f in ${D}/lib/firmware/*; do
+ install -m 644 $f ${DEPLOYDIR}/optee/
+ done
}
addtask deploy before do_build after do_install