aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-10-20 10:01:07 +0200
committerKoen Kooi <koen.kooi@linaro.org>2015-10-20 10:37:33 +0200
commitcb9eb26656c022be9335258ed72da2a397169fc3 (patch)
tree77ffb7451ab453e2541f238488559f8ef8182bdb
parent8a236054eac0cfcda280a22e6b29be0ca843dd6b (diff)
systemd-serialgetty: enable autologin on serial console
The long term solution is to change the lava jobs to login, but for now let's cheat and use autologin in the images. Change-Id: Ib1333d1603d9967e931d6e14d225eaba34da7f71 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-linaro-integration/recipes-core/systemd/systemd-serialgetty.bbappend2
-rw-r--r--meta-linaro-integration/recipes-core/systemd/systemd-serialgetty/serial-getty@.service37
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-linaro-integration/recipes-core/systemd/systemd-serialgetty.bbappend b/meta-linaro-integration/recipes-core/systemd/systemd-serialgetty.bbappend
new file mode 100644
index 00000000..8ec0f197
--- /dev/null
+++ b/meta-linaro-integration/recipes-core/systemd/systemd-serialgetty.bbappend
@@ -0,0 +1,2 @@
+PR = "r5.1"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
diff --git a/meta-linaro-integration/recipes-core/systemd/systemd-serialgetty/serial-getty@.service b/meta-linaro-integration/recipes-core/systemd/systemd-serialgetty/serial-getty@.service
new file mode 100644
index 00000000..bfdb64c7
--- /dev/null
+++ b/meta-linaro-integration/recipes-core/systemd/systemd-serialgetty/serial-getty@.service
@@ -0,0 +1,37 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+
+[Unit]
+Description=Serial Getty on %I
+Documentation=man:agetty(8) man:systemd-getty-generator(8)
+Documentation=http://0pointer.de/blog/projects/serial-console.html
+BindsTo=dev-%i.device
+After=dev-%i.device systemd-user-sessions.service plymouth-quit-wait.service
+After=rc-local.service
+
+# If additional gettys are spawned during boot then we should make
+# sure that this is synchronized before getty.target, even though
+# getty.target didn't actually pull it in.
+Before=getty.target
+IgnoreOnIsolate=yes
+
+[Service]
+Environment="TERM=xterm"
+ExecStart=-/sbin/agetty --autologin root -8 -L --keep-baud %I @BAUDRATE@ $TERM
+Type=idle
+Restart=always
+RestartSec=0
+UtmpIdentifier=%I
+TTYPath=/dev/%I
+TTYReset=yes
+TTYVHangup=yes
+KillMode=process
+IgnoreSIGPIPE=no
+SendSIGHUP=yes
+
+[Install]
+WantedBy=getty.target