aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-10-28 10:22:56 +0100
committerKoen Kooi <koen.kooi@linaro.org>2015-10-28 10:22:56 +0100
commit5cc4441fb538d6f37b62d8ee7d204c882df487cb (patch)
treece72cd1a807a6abce482786f103b18fea6e11d58
parentcb9eb26656c022be9335258ed72da2a397169fc3 (diff)
linaro-image-common: run dhcp client on all ethernet ports
Anders reported that networking devices weren't coming up after the switch to systemd, so let's copy the angstrom hack [1]. Also remove the verbose tweak now that sysvinit is gone. [1] https://github.com/Angstrom-distribution/meta-angstrom/blob/1dba0eed7074b080b7391d7f90bd2d8bcc2d2eb0/recipes-images/angstrom/angstrom-image.bb#L27 Change-Id: I9fbb5fdf01699864adff3479a9dd431928caac27 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-common.inc21
1 files changed, 18 insertions, 3 deletions
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-common.inc b/meta-linaro/recipes-linaro/images/linaro-image-common.inc
index 46ff33db..65ac920a 100644
--- a/meta-linaro/recipes-linaro/images/linaro-image-common.inc
+++ b/meta-linaro/recipes-linaro/images/linaro-image-common.inc
@@ -89,9 +89,24 @@ SDK_IMAGE_INSTALL += "\
${HUGETLB} \
"
-IMAGE_PREPROCESS_COMMAND += "make_boot_verbose; "
+IMAGE_PREPROCESS_COMMAND += "do_systemd_network ; "
+do_systemd_network () {
+ install -d ${IMAGE_ROOTFS}${sysconfdir}/systemd/network
+ cat << EOF > ${IMAGE_ROOTFS}${sysconfdir}/systemd/network/10-en.network
+[Match]
+Name=en*
-fakeroot make_boot_verbose () {
- sed -i -e 's/VERBOSE=no/VERBOSE=yes/' ${IMAGE_ROOTFS}/etc/default/rcS
+[Network]
+DHCP=yes
+EOF
+
+ cat << EOF > ${IMAGE_ROOTFS}${sysconfdir}/systemd/network/11-eth.network
+[Match]
+Name=eth*
+
+[Network]
+DHCP=yes
+EOF
}
+