aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-04-25 00:09:31 -0700
committerKen Werner <ken.werner@linaro.org>2012-04-30 10:53:04 +0200
commitcd5fa2188313f5202555d87379489c79945fec94 (patch)
treed25a403f554b4cef826a82491e98b4264334c766
parentcad2f0008b28ddf0904b6aae921add51a2f3931c (diff)
linux-yocto_3.2.bbappend: Fix the COMPATIBLE_MACHINE override
This was conflicting with other layers and also fix FILESEXTRAPATHS to evaluate immediate instead of lazy evaluation in which case THISDIR would have been wrong. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-yocto_3.2.bbappend5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-yocto_3.2.bbappend b/recipes-kernel/linux/linux-yocto_3.2.bbappend
index 1514adfe..eec49245 100644
--- a/recipes-kernel/linux/linux-yocto_3.2.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -1,9 +1,8 @@
KMACHINE_qemuarmv7a = "arm-versatile-926ejs"
KBRANCH_qemuarmv7a = "standard/default/arm-versatile-926ejs"
+OMPATIBLE_MACHINE_qemuarmv7a = "qemuarmv7a"
-COMPATIBLE_MACHINE = "(qemuarm|qemuarmv7a|qemux86|qemuppc|qemumips|qemux86-64)"
-
-FILESEXTRAPATHS =. "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS := "${THISDIR}/${PN}/${MACHINE}:"
DEFCONFIG = ""
DEFCONFIG_qemuarmv7a = "file://defconfig"