aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-30 15:02:35 +0100
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-30 15:02:35 +0100
commitea4b2f837794fda8087a5c0af392ed711ebec704 (patch)
treebee1c0f10a3cea453cb9d68b415a39735a3bc880
parent41d69f4e15c1bc71f74481006837fb59c8167d6f (diff)
linaro-lava-tests: added mysql.php and moved hello.* to /home/root/
mysql.php for https://bugs.launchpad.net/linaro-oe/+bug/1068750 hello.c{c} moved to /home/root as this is $HOME for root in OE Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
-rw-r--r--recipes-linaro/linaro-lava-tests/files/mysql.php9
-rw-r--r--recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb9
2 files changed, 14 insertions, 4 deletions
diff --git a/recipes-linaro/linaro-lava-tests/files/mysql.php b/recipes-linaro/linaro-lava-tests/files/mysql.php
new file mode 100644
index 00000000..258b1848
--- /dev/null
+++ b/recipes-linaro/linaro-lava-tests/files/mysql.php
@@ -0,0 +1,9 @@
+<?php
+
+$link = mysql_connect('localhost', 'root', '');
+if (!$link) {
+ die('MySQL error: ' . mysql_error());
+}
+echo 'Connected with MySQL';
+mysql_close($link);
+?>
diff --git a/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb b/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb
index 9e6a09ad..389d2ff4 100644
--- a/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb
+++ b/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb
@@ -1,21 +1,22 @@
DESCRIPTION = "Scripts and files for LAVA tests"
LICENSE = "Expat"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3725c2bb543d06ff759f9db9b5d986ac"
+PR = "r2"
SRC_URI = "\
file://hello.c \
file://hello.cc \
file://info.php \
+ file://mysql.php \
file://LICENSE \
"
S = "${WORKDIR}"
do_install() {
- install -d ${D}/root ${D}/usr/share/apache2/htdocs/
- install -m 0644 hello.c ${D}/root/
- install -m 0644 hello.cc ${D}/root/
- install -m 0644 info.php ${D}/usr/share/apache2/htdocs/
+ install -d ${D}/home/root ${D}/usr/share/apache2/htdocs/
+ install -m 0644 hello.* ${D}/home/root/
+ install -m 0644 *.php ${D}/usr/share/apache2/htdocs/
}
FILES_${PN} = "/"