aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Haslam <stuart.haslam@linaro.org>2015-12-10 11:53:57 +0000
committerStuart Haslam <stuart.haslam@linaro.org>2015-12-10 11:54:35 +0000
commitb0e2b733c4350caec4d5a3dd75da5de9acad5fa7 (patch)
tree02e28fa420c1b6ba3da2a22d44f61274e83d943f
parent1bf4dfc6e0719be940f75c3d155382deabac80f2 (diff)
meta-linaro: odp: update to v1.5.0.015.12
ODP now supports installing test binaries to a specific directory and includes a script to run the installed tests, so use these for ptest. Change-Id: I72c25e69e22a8211f7bd9cbe8be29d333da4d474 Signed-off-by: Stuart Haslam <stuart.haslam@linaro.org>
-rw-r--r--meta-linaro/recipes-extra/odp/odp/run-ptest41
-rw-r--r--meta-linaro/recipes-extra/odp/odp_v1.5.0.0.bb (renamed from meta-linaro/recipes-extra/odp/odp_v1.0.3.bb)20
2 files changed, 6 insertions, 55 deletions
diff --git a/meta-linaro/recipes-extra/odp/odp/run-ptest b/meta-linaro/recipes-extra/odp/odp/run-ptest
deleted file mode 100644
index a3e2cf66..00000000
--- a/meta-linaro/recipes-extra/odp/odp/run-ptest
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-#
-# Run all of the ODP test applications and report status in a format
-# that matches the automake "make check" output.
-#
-res=0
-
-if [ "$1" != "-v" ]; then
- verbose=0
- mkdir -p logs
-else
- verbose=1
-fi
-
-TESTS=$(find test/* -type f -executable | grep -v .debug | sort)
-
-if [ "$TESTS" = "" ]; then
- echo "Failed to find any test executables"
- exit 1
-fi
-
-for tc in $TESTS; do
- tcname=$(basename $tc)
-
- if [ "$verbose" = "0" ]; then
- logfile=logs/${tcname}.log
- touch $logfile || logfile=/dev/null
- $tc > $logfile 2>&1
- else
- $tc
- fi
-
- tres=$?
- case $tres in
- 0) echo "PASS: $tcname" ;;
- 77) echo "SKIP: $tcname" ;;
- *) echo "FAIL: $tcname"; res=1 ;;
- esac
-done
-
-exit $res
diff --git a/meta-linaro/recipes-extra/odp/odp_v1.0.3.bb b/meta-linaro/recipes-extra/odp/odp_v1.5.0.0.bb
index c9124f0f..e777821e 100644
--- a/meta-linaro/recipes-extra/odp/odp_v1.0.3.bb
+++ b/meta-linaro/recipes-extra/odp/odp_v1.5.0.0.bb
@@ -6,12 +6,11 @@ SECTION = "console/network"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4ccfa994aa96974cfcd39a59faee20a2"
-DEPENDS = "openssl cunit"
+DEPENDS = "openssl cunit libpcap"
-SRC_URI = "git://git.linaro.org/lng/odp.git;name=odp \
- file://run-ptest"
+SRC_URI = "git://git.linaro.org/lng/odp.git;name=odp"
-SRCREV_odp = "1bc6f09703cfa1cb0cb6632af2106ed4238784b0"
+SRCREV_odp = "4c060d0c97b3521b30b7a3f5e19f3317a803ca77"
SRCREV_FORMAT = "odp"
S = "${WORKDIR}/git"
@@ -21,19 +20,12 @@ inherit autotools ptest
PACKAGECONFIG[perf] = "--enable-test-perf,,,"
do_configure_ptest() {
- oe_runconf --enable-test-vald
-}
-
-do_compile_ptest() {
- oe_runmake -C test/validation buildtest-TESTS
+ oe_runconf --enable-test-vald --with-testdir=${PTEST_PATH}/test/
}
do_install_ptest() {
- DESTDIR=${D}/${PTEST_PATH}/test/
- oe_runmake -C test/validation install-binPROGRAMS \
- BUILDDIR=${B} DESTDIR=${DESTDIR}
- find ${DESTDIR} -type f -executable -exec mv -f {} ${DESTDIR} \;
- rm -rf ${DESTDIR}/usr
+ oe_runmake DESTDIR=${D} install
+ ln -s test/run-test ${D}/${PTEST_PATH}/run-ptest
}
# ODP is primarily shipped as static library plus some API test and samples/