aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-20 06:08:06 +0000
committerFathi Boudra <fathi.boudra@linaro.org>2015-02-20 08:11:13 +0200
commite6e66d3c93c571e82635ac1e5d83fffbcaaf144f (patch)
tree306e2e9966d443ddbac76796207313cdebc89a66
parent3eaede2cfe054456b30d4f026916ed35aea21b04 (diff)
glibc,external-toolchain: spare the native and nativesdk recipe variants
We should make this change only when TARGET recipes are concerned since we use glibc for native and nativesdk providers even on uclibc and musl systems Change-Id: Ia93c5d808320516e856d77dee00479e653eea553 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb10
-rw-r--r--meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb3
2 files changed, 6 insertions, 7 deletions
diff --git a/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb b/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
index cf41fb9c..63f03833 100644
--- a/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
+++ b/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
@@ -98,16 +98,14 @@ GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-${PV}', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
#
-# For now, we will skip building of a gcc package if it is a uclibc one
-# and our build is not a uclibc one, and we skip a glibc one if our build
-# is a uclibc build.
-#
-# See the note in gcc/gcc_3.4.0.oe
+# We will skip parsing glibc when system C library selection is not glibc
+# this helps in easing out parsing for non-glibc system libraries
#
python __anonymous () {
import re
- if d.getVar("TCLIBC", True) != "glibc":
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))
}
diff --git a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
index fc4e30eb..28ab4d78 100644
--- a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
+++ b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
@@ -410,7 +410,8 @@ python () {
if not d.getVar("ELT_VER_MAIN"):
raise bb.parse.SkipPackage("External Linaro toolchain not configured (ELT_VER_MAIN not set).")
import re
- if d.getVar("TCLIBC", True) != "glibc":
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))
}