aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2015-06-23 20:51:50 +0200
committerAnders Roxell <anders.roxell@linaro.org>2015-06-25 12:49:59 +0200
commitac8fa8da06a75c3eec763a00d4d4a8cb21ff4acd (patch)
treef2fc6c72889cb0d2b829637086065b8dd429344e
parent0922ad0fc8e290ad3b1c142d99f186372ed3a22b (diff)
recipes-kernel/linux: linux-lng-*test-x86-64 recipes
Change-Id: I5443f9eb5d75964fdde98f4c1e3705bb85f14e98 Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
-rw-r--r--meta-linaro/recipes-kernel/linux/linaro-lng-rt-test-x86-64_3.14.bb20
-rw-r--r--meta-linaro/recipes-kernel/linux/linaro-lng-test-x86-64_3.14.bb19
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/linux/linaro-lng-rt-test-x86-64_3.14.bb b/meta-linaro/recipes-kernel/linux/linaro-lng-rt-test-x86-64_3.14.bb
new file mode 100644
index 00000000..2c266a42
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/linaro-lng-rt-test-x86-64_3.14.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linaro LNG Kernel For x86"
+PV = "3.14+git${SRCPV}"
+
+require linaro-lng.inc
+
+SRC_URI = "git://git.linaro.org/kernel/linux-linaro-lng.git;branch=linux-linaro-lng-v3.14-rt-test"
+
+do_configure_prepend() {
+ cd ${S}
+ scripts/kconfig/merge_config.sh -m arch/x86/configs/x86_64_defconfig \
+ linaro/configs/preempt-rt.conf \
+ linaro/configs/ovs.conf \
+ linaro/configs/kvm-host.conf \
+ linaro/configs/no_hz_full.conf
+ scripts/config -e CONFIG_DEVTMPFS
+ scripts/config -e CONFIG_DEVTMPFS_MOUNT
+ scripts/config -e CONFIG_E1000E
+ scripts/config -e CONFIG_IXGBE
+ cd ${B}
+}
diff --git a/meta-linaro/recipes-kernel/linux/linaro-lng-test-x86-64_3.14.bb b/meta-linaro/recipes-kernel/linux/linaro-lng-test-x86-64_3.14.bb
new file mode 100644
index 00000000..f8de2da5
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/linaro-lng-test-x86-64_3.14.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Linaro LNG Kernel For x86"
+PV = "3.14+git${SRCPV}"
+
+require linaro-lng.inc
+
+SRC_URI = "git://git.linaro.org/kernel/linux-linaro-lng.git;branch=linux-linaro-lng-v3.14-test"
+
+do_configure_prepend() {
+ cd ${S}
+ scripts/kconfig/merge_config.sh -m arch/x86/configs/x86_64_defconfig \
+ linaro/configs/ovs.conf \
+ linaro/configs/kvm-host.conf \
+ linaro/configs/no_hz_full.conf
+ scripts/config -e CONFIG_DEVTMPFS
+ scripts/config -e CONFIG_DEVTMPFS_MOUNT
+ scripts/config -e CONFIG_E1000E
+ scripts/config -e CONFIG_IXGBE
+ cd ${B}
+}