aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Gregory <graeme.gregory@linaro.org>2014-11-25 13:05:03 +0000
committerGraeme Gregory <graeme.gregory@linaro.org>2014-11-28 10:54:06 +0000
commit89e2375da621d441e6c28f105c29c5d834fba5f7 (patch)
tree21848ad23c6b035cfa1c79f18931e428c66fff71
parent35b44a3ef4b361865cfaf5e2b490cda4158368c5 (diff)
acpicatests : include the actual test script
Include the aapitsrun script which is the actual test script which makes use of the aapits binary to run specific tests. Patched to allow running from abitraty directory instead of assuming results are in ../tmp and binary is in ./ and to not nuke test results at end of script. Change-Id: I46d310cf9f2f1158c2d1ae15263def47209030bb Signed-off-by: Graeme Gregory <graeme.gregory@linaro.org>
-rw-r--r--meta-linaro-integration/recipes-overlayed/acpica/acpitests/0001-aaptisrun-alter-to-allow-destination-directory-as-ar.patch59
-rw-r--r--meta-linaro-integration/recipes-overlayed/acpica/acpitests_20140828.bb2
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-linaro-integration/recipes-overlayed/acpica/acpitests/0001-aaptisrun-alter-to-allow-destination-directory-as-ar.patch b/meta-linaro-integration/recipes-overlayed/acpica/acpitests/0001-aaptisrun-alter-to-allow-destination-directory-as-ar.patch
new file mode 100644
index 00000000..47c2dd2c
--- /dev/null
+++ b/meta-linaro-integration/recipes-overlayed/acpica/acpitests/0001-aaptisrun-alter-to-allow-destination-directory-as-ar.patch
@@ -0,0 +1,59 @@
+From b74f3c497d3fb689d12aed26dd5b8614ca6ac96e Mon Sep 17 00:00:00 2001
+From: Graeme Gregory <graeme.gregory@linaro.org>
+Date: Tue, 25 Nov 2014 12:49:42 +0000
+Subject: [PATCH] aaptisrun : alter to allow destination directory as argument
+
+Also search for appits in $PATH
+
+Upstream-status: Inapropriate [LAVA use only, upstream unmaintained]
+Signed-off-by: Graeme Gregory <graeme.gregory@linaro.org>
+---
+ tests/aapits/bin/aapitsrun | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tests/aapits/bin/aapitsrun b/tests/aapits/bin/aapitsrun
+index cfa999e..3a97a0f 100755
+--- a/tests/aapits/bin/aapitsrun
++++ b/tests/aapits/bin/aapitsrun
+@@ -20,7 +20,7 @@
+
+ # Init variables of utility
+
+-AAPITSDIR=../tmp
++AAPITSDIR="$1"
+
+ AAPITSOUT=${AAPITSDIR}/raw.out
+ AAPITSSUM=${AAPITSDIR}/sum.out
+@@ -56,6 +56,8 @@ TESTS_NUMBERS="$AT_INIT_TEST_NUM $AT_MEMM_TEST_NUM $AT_TBLM_TEST_NUM $AT_NSPM_TE
+
+ # Check the working directory
+
++mkdir -p "$AAPITSDIR/aml" || true
++
+ if [ ! -d "$AAPITSDIR" ]; then
+ echo "There is no directory $AAPITSDIR, run make in ../asl"
+ exit 1
+@@ -68,7 +70,7 @@ if [ ! -d "$AAPITSAML" ]; then
+ exit 1
+ fi
+
+-AAPITS=./aapits
++AAPITS=`which aapits`
+
+ # Check access to AapiTS utility
+
+@@ -144,8 +144,8 @@ echo "tests_fail=$tests_fail"
+ echo "tests_none=$tests_none"
+ echo "tests_fault=$tests_fault"
+
+-echo "End AAPI TS: " $TS_FMT_INIDATE:$TS_FMT_INITIME > $AAPITSOUT
+-echo "End AAPI TS: " $TS_FMT_INIDATE:$TS_FMT_INITIME > $AAPITSSUM
++echo "End AAPI TS: " $TS_FMT_INIDATE:$TS_FMT_INITIME >> $AAPITSOUT
++echo "End AAPI TS: " $TS_FMT_INIDATE:$TS_FMT_INITIME >> $AAPITSSUM
+ echo "End AAPI TS: " $TS_FMT_INIDATE:$TS_FMT_INITIME
+
+ exit 0
+
+--
+2.1.1
+
diff --git a/meta-linaro-integration/recipes-overlayed/acpica/acpitests_20140828.bb b/meta-linaro-integration/recipes-overlayed/acpica/acpitests_20140828.bb
index 889c00be..3f5701bd 100644
--- a/meta-linaro-integration/recipes-overlayed/acpica/acpitests_20140828.bb
+++ b/meta-linaro-integration/recipes-overlayed/acpica/acpitests_20140828.bb
@@ -10,6 +10,7 @@ SRC_URI = "https://acpica.org/sites/acpica/files/acpitests-unix-${PV}.tar.gz;nam
https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz;name=acpica \
file://aapits-linux.patch \
file://aapits-makefile.patch \
+ file://0001-aaptisrun-alter-to-allow-destination-directory-as-ar.patch \
"
SRC_URI[acpitests.md5sum] = "db9d6fdaa8e3eb101d700ee5ba4938ed"
SRC_URI[acpitests.sha256sum] = "e576c74bf1bf1c9f7348bf9419e05c8acfece7105abcdc052e66670c7af2cf00"
@@ -30,6 +31,7 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
install -m0755 tests/aapits/bin/aapits ${D}${bindir}
+ install -m0755 tests/aapits/bin/aapitsrun ${D}${bindir}
}
COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"