aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2014-03-21 16:12:52 +0200
committerRiku Voipio <riku.voipio@linaro.org>2014-03-27 10:59:07 +0200
commit3b25379f74b21c0db3a95c6a3009469b8b8e3b01 (patch)
treed2952cca7171eee1e56382aaaa433aa8100cb497
parentb9fed396b98e58236f9b809fb88e721e1d072b51 (diff)
linaro kernel: pick conf frags from ubuntu-ci
Major reformatting of recipes to pick conf frags from ubuntu-ci. Also removed autorevs and cleaned up bootwrapper building. Change-Id: I9e65941c42c020f5d0f56ab810ae87ed61929e89 Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
-rw-r--r--meta-linaro/recipes-kernel/linux/bootwrapper.inc52
-rw-r--r--meta-linaro/recipes-kernel/linux/linaro-kernel.inc24
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb22
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro-fastmodel.inc63
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro-stable-vexpress_git.bb15
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro-vexpress_git.bb16
6 files changed, 90 insertions, 102 deletions
diff --git a/meta-linaro/recipes-kernel/linux/bootwrapper.inc b/meta-linaro/recipes-kernel/linux/bootwrapper.inc
new file mode 100644
index 00000000..99cc6584
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/bootwrapper.inc
@@ -0,0 +1,52 @@
+SRC_URI_append= " git://git.kernel.org/pub/scm/linux/kernel/git/cmarinas/boot-wrapper-aarch64.git;protocol=http;branch=master;name=bootwrapper;destsuffix=bootwrapper \
+"
+
+SRCREV_bootwrapper = "4266507a84f8c06452109d38e0350d4759740694"
+BW = "${WORKDIR}/bootwrapper"
+DTBDIR="${S}/arch/arm64/boot/dts/"
+
+do_compile_append() {
+ cd ${S}
+ oe_runmake dtbs
+ cd ${BW}
+ autoreconf -vfi
+ ./configure --host=aarch64-linux-gnu \
+ --with-kernel-dir="${S}" \
+ --with-cmdline="${BOOTARGS_COMMON} root=/dev/vda"
+ make IMAGE=linux-system-foundation.axf clean
+ make DTC=${S}/scripts/dtc/dtc \
+ KERNEL_DTB="${DTBDIR}/foundation-v8.dtb" \
+ IMAGE=linux-system-foundation.axf
+ make IMAGE=img-foundation.axf clean
+ ./configure --host=aarch64-linux-gnu \
+ --with-kernel-dir="${S}" \
+ --with-cmdline="${BOOTARGS_COMMON} root=/dev/vda2"
+ make DTC=${S}/scripts/dtc/dtc \
+ KERNEL_DTB="${DTBDIR}/foundation-v8.dtb" \
+ IMAGE=img-foundation.axf
+ make IMAGE=img.axf clean
+ ./configure --host=aarch64-linux-gnu \
+ --with-kernel-dir="${S}" \
+ --with-cmdline="${BOOTARGS_COMMON} root=/dev/mmcblk0p2"
+ make DTC=${S}/scripts/dtc/dtc \
+ KERNEL_DTB="${DTBDIR}/rtsm_ve-aemv8a.dtb" \
+ IMAGE=img.axf
+}
+
+do_install_append() {
+ install -m 0644 ${BW}/img-foundation.axf ${D}/boot/img-foundation.axf
+}
+
+do_deploy_append() {
+ install -d ${DEPLOYDIR}
+ install -m 0644 ${BW}/img.axf ${DEPLOYDIR}/img-${PV}.axf
+ install -m 0644 ${BW}/linux-system-foundation.axf ${DEPLOYDIR}/linux-system-foundation-${PV}.axf
+ install -m 0644 ${BW}/img-foundation.axf ${DEPLOYDIR}/img-foundation-${PV}.axf
+ cd ${DEPLOYDIR}
+ ln -sf img-${PV}.axf img.axf
+ ln -sf linux-system-foundation-${PV}.axf linux-system-foundation.axf
+ ln -sf img-foundation-${PV}.axf img-foundation.axf
+}
+
+PACKAGES =+ "kernel-bootwrapper"
+FILES_kernel-bootwrapper = "/boot/img-foundation.axf"
diff --git a/meta-linaro/recipes-kernel/linux/linaro-kernel.inc b/meta-linaro/recipes-kernel/linux/linaro-kernel.inc
index d79e6fac..5bbcc458 100644
--- a/meta-linaro/recipes-kernel/linux/linaro-kernel.inc
+++ b/meta-linaro/recipes-kernel/linux/linaro-kernel.inc
@@ -1,4 +1,4 @@
-DESCRIPTION = "Linaro Kernel Basic support recipe"
+DESCRIPTION = "Linaro Kernel common bits"
SECTION = "kernel"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
@@ -6,22 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
inherit kernel siteinfo
require recipes-kernel/linux/linux-dtb.inc
-SRCREV = "${AUTOREV}"
-SRCREV_FORMAT = "kernel"
+SRC_URI = " \
+ git://git.linaro.org/git/ci/ubuntu-kernel-ci.git;protocol=http;branch=master;name=ubuntu-ci;destsuffix=ubuntu-ci \
+"
S = "${WORKDIR}/git"
-COMPATIBLE_HOST = "arm.*"
-KERNEL_IMAGETYPE = "zImage"
-
-do_configure_prepend_arm() {
- ARCH=arm scripts/kconfig/merge_config.sh -m linaro/configs/linaro-base.conf \
- linaro/configs/distribution.conf linaro/configs/vexpress.conf \
- linaro/configs/kvm-guest.conf linaro/configs/kvm-host.conf
-}
-
-do_configure_prepend_armeb() {
- ARCH=arm scripts/kconfig/merge_config.sh -m linaro/configs/linaro-base.conf \
- linaro/configs/distribution.conf linaro/configs/vexpress.conf \
- linaro/configs/bigendian.conf
-}
-
+SRCREV_ubuntu-ci = "cf2ec60533d65de4518b16e24e5a9a4735be1c22"
+SRCREV_FORMAT = "kernel"
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb b/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb
index 5922ea73..c4f8e0fb 100644
--- a/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb
+++ b/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb
@@ -1,12 +1,18 @@
-require linux-linaro-fastmodel.inc
+DESCRIPTION = "Linaro recipe for Aarch64 fast model kernels"
-SRC_URI = " \
- git://git.linaro.org/kernel/linux-linaro-tracking.git;protocol=http;branch=linux-linaro;name=kernel \
- git://git.kernel.org/pub/scm/linux/kernel/git/cmarinas/boot-wrapper-aarch64.git;protocol=http;branch=master;name=bootwrapper;destsuffix=bootwrapper \
-"
+SRCREV_kernel="88236400e1c7d4dd4b59f137cf496aae215af7aa"
+PV = "3.13+git${SRCPV}"
+
+SRC_URI_append = " git://git.linaro.org/git/kernel/linux-linaro-tracking.git;protocol=http;branch=linux-linaro;name=kernel "
+
+include linaro-kernel.inc
+include bootwrapper.inc
+
+COMPATIBLE_HOST = "aarch64"
+KERNEL_IMAGETYPE = "Image"
+BOOTARGS_COMMON = "console=ttyAMA0 mem=2048M devtmpfs.mount=1 earlyprintk=pl011,0x1c090000 consolelog=9 rw"
do_configure_prepend() {
- ARCH=arm64 scripts/kconfig/merge_config.sh -m linaro/configs/linaro-base.conf \
- linaro/configs/linaro-base64.conf linaro/configs/vexpress64.conf \
- linaro/configs/distribution.conf
+ . ../ubuntu-ci/configs/vexpress64.cfg
+ ARCH=arm64 scripts/kconfig/merge_config.sh -m $linaro_base_config_frags $ubuntu_config_frag $board_config_frags
}
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro-fastmodel.inc b/meta-linaro/recipes-kernel/linux/linux-linaro-fastmodel.inc
deleted file mode 100644
index adcb784a..00000000
--- a/meta-linaro/recipes-kernel/linux/linux-linaro-fastmodel.inc
+++ /dev/null
@@ -1,63 +0,0 @@
-DESCRIPTION = "Linaro recipes for Aarch64 fast model kernels"
-SECTION = "kernel"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-inherit kernel siteinfo
-
-PV = "3.13+git${SRCPV}"
-
-SRCREV_bootwrapper = "${AUTOREV}"
-SRCREV_kernel = "${AUTOREV}"
-SRCREV_FORMAT = "kernel"
-
-S = "${WORKDIR}/git"
-BW = "${WORKDIR}/bootwrapper"
-
-COMPATIBLE_HOST = "aarch64"
-KERNEL_IMAGETYPE = "Image"
-
-PACKAGES =+ "kernel-bootwrapper"
-FILES_kernel-bootwrapper = "/boot/img-foundation.axf"
-
-BOOTARGS_COMMON = "console=ttyAMA0 mem=2048M devtmpfs.mount=1 earlyprintk=pl011,0x1c090000 consolelog=9 rw"
-
-do_compile_append() {
- CROSS=`echo $CC|sed -e s/gcc.*//`
- install -m 0644 ${S}/arch/arm64/boot/Image ${BW}/
- install -m 0644 ${S}/arch/arm64/boot/dts/*.dts* ${BW}/
- cd ${BW}
- make clean
- make DTC=${S}/scripts/dtc/dtc \
- FDT_SRC=foundation-v8.dts \
- CROSS_COMPILE=$CROSS \
- IMAGE=linux-system-foundation.axf \
- BOOTARGS='"${BOOTARGS_COMMON} root=/dev/vda"'
- make clean
- make DTC=${S}/scripts/dtc/dtc \
- FDT_SRC=foundation-v8.dts \
- CROSS_COMPILE=$CROSS \
- IMAGE=img-foundation.axf \
- BOOTARGS='"${BOOTARGS_COMMON} root=/dev/vda2"'
- make clean
- make DTC=${S}/scripts/dtc/dtc \
- FDT_SRC=rtsm_ve-aemv8a.dts \
- CROSS_COMPILE=$CROSS \
- IMAGE=linux-system-ve.axf \
- BOOTARGS='"${BOOTARGS_COMMON} root=/dev/mmcblk0"'
-}
-
-do_install_append() {
- install -m 0644 ${BW}/img-foundation.axf ${D}/boot/img-foundation.axf
-}
-
-do_deploy_append() {
- install -d ${DEPLOYDIR}
- install -m 0644 ${BW}/linux-system-ve.axf ${DEPLOYDIR}/linux-system-ve-${KERNEL_IMAGE_BASE_NAME}.axf
- install -m 0644 ${BW}/linux-system-foundation.axf ${DEPLOYDIR}/linux-system-foundation-${KERNEL_IMAGE_BASE_NAME}.axf
- install -m 0644 ${BW}/img-foundation.axf ${DEPLOYDIR}/img-foundation-${KERNEL_IMAGE_BASE_NAME}.axf
- cd ${DEPLOYDIR}
- ln -sf linux-system-ve-${KERNEL_IMAGE_BASE_NAME}.axf linux-system-ve.axf
- ln -sf linux-system-foundation-${KERNEL_IMAGE_BASE_NAME}.axf linux-system-foundation.axf
- ln -sf img-foundation-${KERNEL_IMAGE_BASE_NAME}.axf img-foundation.axf
-}
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro-stable-vexpress_git.bb b/meta-linaro/recipes-kernel/linux/linux-linaro-stable-vexpress_git.bb
index 7138a628..5e31b4d6 100644
--- a/meta-linaro/recipes-kernel/linux/linux-linaro-stable-vexpress_git.bb
+++ b/meta-linaro/recipes-kernel/linux/linux-linaro-stable-vexpress_git.bb
@@ -1,13 +1,16 @@
DESCRIPTION = "Linaro Stable Kernel For Vexpress/KVM"
-require linaro-kernel.inc
-
PV = "3.10+git${SRCPV}"
+SRCREV_kernel="d3222d77b27a07a4b200d1b0b792e8e3bdf30396"
+SRC_URI_append = " git://git.linaro.org/git/kernel/linux-linaro-stable.git;protocol=http;branch=linux-linaro-lsk;name=kernel "
+require linaro-kernel.inc
KERNEL_DEVICETREE = "vexpress-v2p-ca15-tc1.dtb"
-
BOOTARGS_COMMON = "root=/dev/mmcblk0p2 console=ttyAMA0 consolelog=9 mem=1024M rw rootwait"
+COMPATIBLE_HOST = "arm.*"
+KERNEL_IMAGETYPE = "zImage"
-SRC_URI = "git://git.linaro.org/kernel/linux-linaro-stable.git;protocol=http;branch=lsk"
-
-
+do_configure_prepend() {
+ . ../ubuntu-ci/configs/lsk-vexpress.cfg
+ ARCH=arm scripts/kconfig/merge_config.sh -m $linaro_base_config_frags $ubuntu_config_frag $board_config_frags
+}
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro-vexpress_git.bb b/meta-linaro/recipes-kernel/linux/linux-linaro-vexpress_git.bb
index 090f2bab..160fe840 100644
--- a/meta-linaro/recipes-kernel/linux/linux-linaro-vexpress_git.bb
+++ b/meta-linaro/recipes-kernel/linux/linux-linaro-vexpress_git.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "Linaro Kernel For Vexpress/KVM"
+SRCREV_kernel="88236400e1c7d4dd4b59f137cf496aae215af7aa"
+PV = "3.13+git${SRCPV}"
+SRC_URI_append = " git://git.linaro.org/git/kernel/linux-linaro-tracking.git;protocol=http;branch=linux-linaro;name=kernel "
require linaro-kernel.inc
-SRCREV = "2a0563041d1672e7e2e09703aa4d3feffc72053c"
-PV = "3.11+git${SRCPV}"
-
KERNEL_DEVICETREE = "vexpress-v2p-ca15-tc1.dtb"
-
BOOTARGS_COMMON = "root=/dev/mmcblk0p2 console=ttyAMA0 consolelog=9 mem=1024M rw rootwait"
+COMPATIBLE_HOST = "arm.*"
+KERNEL_IMAGETYPE = "zImage"
-SRC_URI = "git://git.linaro.org/kernel/linux-linaro-tracking.git;protocol=http;branch=linux-linaro"
-
-
+do_configure_prepend() {
+ . ../ubuntu-ci/configs/vexpress.cfg
+ ARCH=arm scripts/kconfig/merge_config.sh -m $linaro_base_config_frags $ubuntu_config_frag $board_config_frags
+}