aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2019-01-28 23:56:13 +0100
committerAnders Roxell <anders.roxell@linaro.org>2019-01-28 23:58:22 +0100
commit56ae5b0b49e3a41fe5fd9b24248206485eb9546d (patch)
tree6dc7363d5a75c109b8ed99ee4097a4a6b6e82a4c
parent1bfca595cb0f88047a288529bbe3296264cba899 (diff)
libgpiod: import from meta-oe - update to use 1.2rocko
default in rocko meta-oe uses 0.3.1 we want to use a later version. Change-Id: Ie1a3fae06ecb70bc48a87ce3dff8fe9eacb4b57d Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
-rw-r--r--openembedded-layer/recipes-support/libgpiod/libgpiod.inc21
-rw-r--r--openembedded-layer/recipes-support/libgpiod/libgpiod_1.2.bb16
2 files changed, 37 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-support/libgpiod/libgpiod.inc b/openembedded-layer/recipes-support/libgpiod/libgpiod.inc
new file mode 100644
index 0000000..cd77506
--- /dev/null
+++ b/openembedded-layer/recipes-support/libgpiod/libgpiod.inc
@@ -0,0 +1,21 @@
+SUMMARY = "C library and tools for interacting with the linux GPIO character device"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
+
+SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
+
+inherit autotools pkgconfig
+
+# enable tools
+PACKAGECONFIG ?= "tools"
+
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
+
+PACKAGES =+ " ${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}/*"
+
+RRECOMMENDS_TOOLS = "${@bb.utils.contains('PACKAGECONFIG', 'tools', '${PN}-tools', '',d)}"
+RRECOMMENDS_${PN} += "${RRECOMMENDS_TOOLS}"
diff --git a/openembedded-layer/recipes-support/libgpiod/libgpiod_1.2.bb b/openembedded-layer/recipes-support/libgpiod/libgpiod_1.2.bb
new file mode 100644
index 0000000..93165a0
--- /dev/null
+++ b/openembedded-layer/recipes-support/libgpiod/libgpiod_1.2.bb
@@ -0,0 +1,16 @@
+require libgpiod.inc
+
+DEPENDS += "autoconf-archive-native"
+
+SRC_URI[md5sum] = "34a9972f2f4e9c32fa940301301b007d"
+SRC_URI[sha256sum] = "b6b9079c933f7c8524815437937dda6b795a16141bca202a9eec70ba5844b5ba"
+
+PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
+
+PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)}
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
+RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
+RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"