aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 10 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index c92023866..6bbb0ae03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odp_version_generation], [1])
-m4_define([odp_version_major], [37])
-m4_define([odp_version_minor], [2])
+m4_define([odp_version_major], [38])
+m4_define([odp_version_minor], [0])
m4_define([odp_version_patch], [0])
m4_define([odp_version_api],
@@ -42,12 +42,6 @@ AC_SUBST(ODPH_VERSION_MINOR)
ODPH_VERSION=odph_version
AC_SUBST(ODPH_VERSION)
-##########################################################################
-# Test if user has set CFLAGS. Automake initializes CFLAGS to "-g -O2"
-# by default.
-##########################################################################
-AS_IF([test "$ac_cv_env_CFLAGS_set" = ""], [user_cflags=0], [user_cflags=1])
-
# Initialize automake
AM_INIT_AUTOMAKE([1.9 tar-pax subdir-objects foreign nostdinc -Wall -Werror])
AC_CONFIG_SRCDIR([include/odp/api/spec/init.h])
@@ -255,9 +249,9 @@ AC_ARG_ENABLE([lto],
# binutils), but object files are larger.
ODP_LTO_FLAGS="-flto -ffat-lto-objects"
fi])
-AC_SUBST(ODP_LTO_FLAGS)
ODP_CFLAGS="$ODP_CFLAGS $ODP_LTO_FLAGS"
+ODP_LDFLAGS="$ODP_LDFLAGS $ODP_LTO_FLAGS"
##########################################################################
# Build examples/tests dynamically
@@ -418,10 +412,6 @@ DX_INIT_DOXYGEN($PACKAGE_NAME,
##########################################################################
# Default include setup
##########################################################################
-CFLAGS="$ODP_CFLAGS $CFLAGS"
-CXXFLAGS="$ODP_CXXFLAGS $CXXFLAGS"
-LDFLAGS="$ODP_LTO_FLAGS $LDFLAGS"
-
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([include/Makefile
include/odp/api/spec/version.h
@@ -433,10 +423,10 @@ AC_CONFIG_FILES([helper/Makefile
##########################################################################
# distribute the changed variables among the Makefiles
-AC_SUBST([LIBS])
-AC_SUBST([CPPFLAGS])
-AC_SUBST([CFLAGS])
-AC_SUBST([LDFLAGS])
+AC_SUBST([ODP_CFLAGS])
+AC_SUBST([ODP_CXXFLAGS])
+AC_SUBST([ODP_LDFLAGS])
+
AC_SUBST([EXEEXT])
CC_VERSION=$($CC --version | head -n 1)
@@ -467,10 +457,10 @@ AC_MSG_RESULT([
cc: ${CC}
cc version: ${CC_VERSION}
cppflags: ${CPPFLAGS}
- cflags: ${CFLAGS}
- cxxflags: ${CXXFLAGS}
+ cflags: ${ODP_CFLAGS} ${CFLAGS}
+ cxxflags: ${ODP_CXXFLAGS} ${CXXFLAGS}
ld: ${LD}
- ldflags: ${LDFLAGS}
+ ldflags: ${ODP_LDFLAGS} ${LDFLAGS}
libs: ${LIBS}
dependency libs: ${PLAT_DEP_LIBS}
defs: ${DEFS}