aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve McIntyre <steve.mcintyre@linaro.org>2016-03-24 17:50:51 +0000
committerSteve McIntyre <steve.mcintyre@linaro.org>2016-03-24 17:50:51 +0000
commit1588745a5367d6e59d2d0a1e14193fcb3cb7be99 (patch)
tree0788363bdbc5d71042f76fc23f1b95d167bf7645 /debian/rules
parentc03d68da5431390e2f83bdc1c1e45f09e5cd3910 (diff)
Initial Debian packagingdebian
Change-Id: I4190095771711f22de5d248a11eb0697ad9d527a
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1842f50
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PYTHON2:=$(shell pyversions -r)
+install_dir=$(call py_libdir, $(PYTHON2))
+
+%:
+ dh $@ --with python2
+
+override_dh_auto_build:
+ dh_auto_build
+ python setup.py build
+
+# get upstream version for get-orig-source target
+VERSION:= $(shell dpkg-parsechangelog | grep '^Version: ' | sed -e 's/^Version: //' | sed -e 's/\-.*$$//')
+
+sdist-orig:
+ python setup.py sdist
+ mv -v dist/vland-*.tar.gz ../vland_$(VERSION).orig.tar.gz
+ $(RM) -r versiontools-*.egg/