summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-11-04 15:39:04 -0600
committerBen Hutchings <ben@decadent.org.uk>2016-11-04 15:41:12 -0600
commit790f2d1ab500c5d8311176b80e5612be5d1a63c8 (patch)
treefb7533fda4d57104e66ecab264fbeb60f17e9821
parentd88288583532be63ec75dff7dcb50ff03a0b7c85 (diff)
perf: Disable use of libcrypto (Closes: #843199)
-rw-r--r--debian/changelog1
-rw-r--r--debian/rules.d/tools/perf/Makefile9
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 99c9dc2bc..b3f02eac6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -120,6 +120,7 @@ linux (4.8.6-1) UNRELEASED; urgency=medium
- drivers/zram: Don't disable preemption in zcomp_stream_get/put()
* HID: Enable HID_ALPS, HID_ASUS (Closes: #843085), HID_CMEDIA as modules
* cpupower: Fix checks for CPU existence (Closes: #843071)
+ * perf: Disable use of libcrypto (Closes: #843199)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 02 Nov 2016 12:01:42 -0600
diff --git a/debian/rules.d/tools/perf/Makefile b/debian/rules.d/tools/perf/Makefile
index 1bf415e08..aa50e42ef 100644
--- a/debian/rules.d/tools/perf/Makefile
+++ b/debian/rules.d/tools/perf/Makefile
@@ -43,6 +43,11 @@ MAKE_PERF += perfexecdir=lib/perf_$(VERSION)-core plugindir=/usr/lib/traceevent_
# cplus_demangle() can be found in libiberty (LGPL v2.1+).
MAKE_PERF += feature-libbfd=0 HAVE_CPLUS_DEMANGLE_SUPPORT=1
+# perf can link against libcrypto if available, but the result is
+# undistributable as GPL v2 and OpenSSL are not compatible without
+# an explicit exception. Override detection of libcrypto.
+MAKE_PERF += NO_LIBCRYPTO=1
+
all:
ifdef KERNEL_ARCH_PERF
# perf changes some default directories depending on whether DESTDIR is
@@ -52,9 +57,9 @@ ifdef KERNEL_ARCH_PERF
ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+$(MAKE_PERF) -C $(top_srcdir)/tools/perf/Documentation man VERSION=$(VERSION)
endif
-# Check that perf didn't get linked against libbfd
+# Check that perf didn't get linked against libbfd or libcrypto
type ldd
- ! ldd $(CURDIR)/perf | grep '\blibbfd'
+ ! ldd $(CURDIR)/perf | grep -E '\blib(bfd|crypto)'
# Check that it includes cplus_demangle from libiberty
grep cplus_demangle $(CURDIR)/perf
endif