aboutsummaryrefslogtreecommitdiff
path: root/debian/rules.d/2-binary-arch.mk
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/2-binary-arch.mk')
-rw-r--r--debian/rules.d/2-binary-arch.mk18
1 files changed, 11 insertions, 7 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 4d4378b3cc1..46a05b4c663 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -364,14 +364,18 @@ ifneq ($(skipdbg),true)
# package from being mirrored. It is instead, through some
# archive admin hackery, copied to http://ddebs.ubuntu.com.
#
- mv ../$(dbgpkg)_$(release)-$(revision)_$(arch).deb \
- ../$(dbgpkg)_$(release)-$(revision)_$(arch).ddeb
+ # Only do this for PRIMARY archive for now
+ #
set -e; \
- if grep -qs '^Build-Debug-Symbols: yes$$' /CurrentlyBuilding; then \
- sed -i '/^$(dbgpkg)_/s/\.deb /.ddeb /' debian/files; \
- else \
- grep -v '^$(dbgpkg)_.*$$' debian/files > debian/files.new; \
- mv debian/files.new debian/files; \
+ if grep -qs '^Purpose: PRIMARY$$' /CurrentlyBuilding; then \
+ mv ../$(dbgpkg)_$(release)-$(revision)_$(arch).deb \
+ ../$(dbgpkg)_$(release)-$(revision)_$(arch).ddeb; \
+ if grep -qs '^Build-Debug-Symbols: yes$$' /CurrentlyBuilding; then \
+ sed -i '/^$(dbgpkg)_/s/\.deb /.ddeb /' debian/files; \
+ else \
+ grep -v '^$(dbgpkg)_.*$$' debian/files > debian/files.new; \
+ mv debian/files.new debian/files; \
+ fi; \
fi
# Now, the package wont get into the archive, but it will get put
# into the debug system.