aboutsummaryrefslogtreecommitdiff
path: root/final/Bitcode/Benchmarks/Halide/local_laplacian/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'final/Bitcode/Benchmarks/Halide/local_laplacian/CMakeLists.txt')
-rw-r--r--final/Bitcode/Benchmarks/Halide/local_laplacian/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/final/Bitcode/Benchmarks/Halide/local_laplacian/CMakeLists.txt b/final/Bitcode/Benchmarks/Halide/local_laplacian/CMakeLists.txt
new file mode 100644
index 00000000..006a3772
--- /dev/null
+++ b/final/Bitcode/Benchmarks/Halide/local_laplacian/CMakeLists.txt
@@ -0,0 +1,10 @@
+file(GLOB bcsources ${CMAKE_CURRENT_SOURCE_DIR}/../common/x86_halide_runtime.bc ${CMAKE_CURRENT_SOURCE_DIR}/local_laplacian.bc)
+SET_SOURCE_FILES_PROPERTIES(${bcsources} PROPERTIES LANGUAGE CXX)
+
+test_img_input(rgb 8 1 1 10)
+test_img_input(rgba 8 1 1 10)
+
+llvm_multisource(halide_local_laplacian
+ ${CMAKE_CURRENT_SOURCE_DIR}/driver.cpp
+ ${bcsources}
+)