aboutsummaryrefslogtreecommitdiff
path: root/SingleSource/UnitTests/Vector/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'SingleSource/UnitTests/Vector/CMakeLists.txt')
-rw-r--r--SingleSource/UnitTests/Vector/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/SingleSource/UnitTests/Vector/CMakeLists.txt b/SingleSource/UnitTests/Vector/CMakeLists.txt
index 839bd69a..a5c8cd08 100644
--- a/SingleSource/UnitTests/Vector/CMakeLists.txt
+++ b/SingleSource/UnitTests/Vector/CMakeLists.txt
@@ -13,8 +13,13 @@ if(ARCH STREQUAL "AArch64")
endif()
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
- if(ARCH STREQUAL "x86" AND X86CPU_ARCH STREQUAL "skylake-avx512")
- add_subdirectory(AVX512)
+ if(ARCH STREQUAL "x86")
+ if(X86CPU_ARCH STREQUAL "skylake-avx512")
+ add_subdirectory(AVX512F)
+ endif()
+ if(X86CPU_ARCH STREQUAL "knl")
+ add_subdirectory(AVX512F)
+ endif()
endif()
endif()
llvm_singlesource(PREFIX "Vector-")