aboutsummaryrefslogtreecommitdiff
path: root/MultiSource/Applications/sqlite3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'MultiSource/Applications/sqlite3/CMakeLists.txt')
-rw-r--r--MultiSource/Applications/sqlite3/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/MultiSource/Applications/sqlite3/CMakeLists.txt b/MultiSource/Applications/sqlite3/CMakeLists.txt
index 618cafa9..3eeb4141 100644
--- a/MultiSource/Applications/sqlite3/CMakeLists.txt
+++ b/MultiSource/Applications/sqlite3/CMakeLists.txt
@@ -1,6 +1,5 @@
list(APPEND CPPFLAGS -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DSQLITE_OMIT_LOAD_EXTENSION=1 -DSQLITE_THREADSAFE=0 -I.)
-set(RUN_OPTIONS -init ${CMAKE_CURRENT_SOURCE_DIR}/sqlite3rc :memory: < ${CMAKE_CURRENT_SOURCE_DIR}/commands)
-set(WORKDIR ${CMAKE_CURRENT_BINARY_DIR})
+set(RUN_OPTIONS -init sqlite3rc :memory: < commands)
set(FP_TOLERANCE 1.0e-9)
set(GeneratedTestInputs ${CMAKE_CURRENT_BINARY_DIR}/test15.sql)
@@ -19,3 +18,4 @@ llvm_multisource(sqlite3
shell.c
)
add_dependencies(sqlite3 sqlite_input)
+llvm_test_data(sqlite3 sqlite3rc commands)