aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CINT95/129.compress/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'External/SPEC/CINT95/129.compress/CMakeLists.txt')
-rw-r--r--External/SPEC/CINT95/129.compress/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/External/SPEC/CINT95/129.compress/CMakeLists.txt b/External/SPEC/CINT95/129.compress/CMakeLists.txt
index 614535d6..91d51f30 100644
--- a/External/SPEC/CINT95/129.compress/CMakeLists.txt
+++ b/External/SPEC/CINT95/129.compress/CMakeLists.txt
@@ -4,12 +4,11 @@ list(APPEND CFLAGS -Wno-return-type)
macro(test_input run_type input output)
llvm_test_run(RUN_TYPE ${run_type}
- < ${BENCHMARK_DIR}/data/${run_type}/input/${input}
- > ${CMAKE_CURRENT_BINARY_DIR}/${output}
+ WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ < data/${run_type}/input/${input} > ${output}
)
- llvm_test_verify(RUN_TYPE ${run_type} ${FPCMP}
- ${BENCHMARK_DIR}/data/${run_type}/output/${output}
- ${CMAKE_CURRENT_BINARY_DIR}/${output}
+ llvm_test_verify(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ ${FPCMP} data/${run_type}/output/${output} ${output}
)
endmacro()
@@ -17,4 +16,5 @@ test_input(test test.in test.out)
test_input(train test.in test.out)
test_input(ref bigtest.in bigtest.out)
-llvm_test_executable(${PROG} ${Source})
+llvm_test_executable(129.compress ${Source})
+llvm_test_data_spec_default(129.compress)