aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CINT95/124.m88ksim/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'External/SPEC/CINT95/124.m88ksim/CMakeLists.txt')
-rw-r--r--External/SPEC/CINT95/124.m88ksim/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/External/SPEC/CINT95/124.m88ksim/CMakeLists.txt b/External/SPEC/CINT95/124.m88ksim/CMakeLists.txt
index 66aaa438..0f7f5dcf 100644
--- a/External/SPEC/CINT95/124.m88ksim/CMakeLists.txt
+++ b/External/SPEC/CINT95/124.m88ksim/CMakeLists.txt
@@ -111,13 +111,11 @@ endforeach()
macro(test_input run_type)
llvm_test_run(RUN_TYPE ${run_type}
- -c < ${BENCHMARK_DIR}/data/${run_type}/input/${CTLFILE}
- > ${CMAKE_CURRENT_BINARY_DIR}/${run_type}.out
- WORKDIR ${BENCHMARK_DIR}/data/${run_type}/input
+ WORKDIR ${CMAKE_CURRENT_BINARY_DIR}/data/${run_type}/input
+ -c < ${CTLFILE} > ${CMAKE_CURRENT_BINARY_DIR}/${run_type}.out
)
- llvm_test_verify(RUN_TYPE ${run_type} ${FPCMP}
- ${BENCHMARK_DIR}/data/${run_type}/output/${run_type}.out
- ${CMAKE_CURRENT_BINARY_DIR}/${run_type}.out
+ llvm_test_verify(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ ${FPCMP} data/${run_type}/output/${run_type}.out ${run_type}.out
)
endmacro()
@@ -125,4 +123,5 @@ test_input(test)
test_input(train)
test_input(ref)
-llvm_test_executable(${PROG} ${Source})
+llvm_test_executable(124.m88ksim ${Source})
+llvm_test_data_spec_default(124.m88ksim)