aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CINT2006/429.mcf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'External/SPEC/CINT2006/429.mcf/CMakeLists.txt')
-rw-r--r--External/SPEC/CINT2006/429.mcf/CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/External/SPEC/CINT2006/429.mcf/CMakeLists.txt b/External/SPEC/CINT2006/429.mcf/CMakeLists.txt
index 370779b4..6c501f95 100644
--- a/External/SPEC/CINT2006/429.mcf/CMakeLists.txt
+++ b/External/SPEC/CINT2006/429.mcf/CMakeLists.txt
@@ -1,18 +1,14 @@
list(APPEND CPPFLAGS -DWANT_STDC_PROTO)
macro(test_input run_type)
- llvm_test_run(RUN_TYPE ${run_type}
- ${BENCHMARK_DIR}/data/${run_type}/input/inp.in
- > ${CMAKE_CURRENT_BINARY_DIR}/inp.out
- WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ llvm_test_run(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ data/${run_type}/input/inp.in > inp.out
)
- llvm_test_verify(RUN_TYPE ${run_type} ${FPCMP}
- ${BENCHMARK_DIR}/data/${run_type}/output/inp.out
- ${CMAKE_CURRENT_BINARY_DIR}/inp.out
+ llvm_test_verify(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ ${FPCMP} data/${run_type}/output/inp.out inp.out
)
- llvm_test_verify(RUN_TYPE ${run_type} ${FPCMP}
- ${BENCHMARK_DIR}/data/${run_type}/output/mcf.out
- ${CMAKE_CURRENT_BINARY_DIR}/mcf.out
+ llvm_test_verify(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ ${FPCMP} data/${run_type}/output/mcf.out mcf.out
)
endmacro()
@@ -20,4 +16,5 @@ test_input(test)
test_input(train)
test_input(ref)
-llvm_test_executable(${PROG} ${Source})
+llvm_test_executable(429.mcf ${Source})
+llvm_test_data_spec_default(429.mcf)