aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CINT2000/197.parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'External/SPEC/CINT2000/197.parser/CMakeLists.txt')
-rw-r--r--External/SPEC/CINT2000/197.parser/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/External/SPEC/CINT2000/197.parser/CMakeLists.txt b/External/SPEC/CINT2000/197.parser/CMakeLists.txt
index 63705b2c..8c341ceb 100644
--- a/External/SPEC/CINT2000/197.parser/CMakeLists.txt
+++ b/External/SPEC/CINT2000/197.parser/CMakeLists.txt
@@ -4,14 +4,13 @@ endif()
macro(test_input run_type)
llvm_test_run(RUN_TYPE ${run_type}
+ WORKDIR ${CMAKE_CURRENT_BINARY_DIR}/data/all/input
2.1.dict -batch
- < ${BENCHMARK_DIR}/data/${run_type}/input/${run_type}.in
+ < ${CMAKE_CURRENT_BINARY_DIR}/data/${run_type}/input/${run_type}.in
> ${CMAKE_CURRENT_BINARY_DIR}/${run_type}.out
- WORKDIR ${BENCHMARK_DIR}/data/all/input
)
- llvm_test_verify(RUN_TYPE ${run_type} ${FPCMP}
- ${BENCHMARK_DIR}/data/${run_type}/output/${run_type}.out
- ${CMAKE_CURRENT_BINARY_DIR}/${run_type}.out
+ llvm_test_verify(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ ${FPCMP} data/${run_type}/output/${run_type}.out ${run_type}.out
)
endmacro()
@@ -19,4 +18,5 @@ test_input(ref)
test_input(train)
test_input(test)
-llvm_test_executable(${PROG} ${Source})
+llvm_test_executable(197.parser ${Source})
+llvm_test_data_spec_default(197.parser)